aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-support/geoip
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip')
-rw-r--r--meta-networking/recipes-support/geoip/geoip-perl_1.51.bb2
-rw-r--r--meta-networking/recipes-support/geoip/geoip_1.6.12.bb6
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate_2.5.0.bb4
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip-perl_1.51.bb b/meta-networking/recipes-support/geoip/geoip-perl_1.51.bb
index 944c005763..1ee04bd475 100644
--- a/meta-networking/recipes-support/geoip/geoip-perl_1.51.bb
+++ b/meta-networking/recipes-support/geoip/geoip-perl_1.51.bb
@@ -31,5 +31,5 @@ do_install_ptest () {
install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
}
-FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
+FILES:${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
diff --git a/meta-networking/recipes-support/geoip/geoip_1.6.12.bb b/meta-networking/recipes-support/geoip/geoip_1.6.12.bb
index 143100e48e..775398474c 100644
--- a/meta-networking/recipes-support/geoip/geoip_1.6.12.bb
+++ b/meta-networking/recipes-support/geoip/geoip_1.6.12.bb
@@ -54,12 +54,12 @@ do_install() {
}
PACKAGES =+ "${PN}-database"
-FILES_${PN}-database = ""
-FILES_${PN}-database += "${datadir}/GeoIP/*"
+FILES:${PN}-database = ""
+FILES:${PN}-database += "${datadir}/GeoIP/*"
# We cannot do much looking up without databases.
#
-RDEPENDS_${PN} += "${PN}-database"
+RDEPENDS:${PN} += "${PN}-database"
inherit ptest
diff --git a/meta-networking/recipes-support/geoip/geoipupdate_2.5.0.bb b/meta-networking/recipes-support/geoip/geoipupdate_2.5.0.bb
index f4eb2b799d..9494bd36ca 100644
--- a/meta-networking/recipes-support/geoip/geoipupdate_2.5.0.bb
+++ b/meta-networking/recipes-support/geoip/geoipupdate_2.5.0.bb
@@ -18,14 +18,14 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "\
file://ChangeLog.md;md5=11d2e31df0de2be3ccc3e2286c4dafcb \
"
-FILES_${PN} = "/usr/share/GeoIP \
+FILES:${PN} = "/usr/share/GeoIP \
/etc/GeoIP.conf \
/etc/cron.d/geoipupdate.cron \
/usr/bin/geoipupdate \
"
inherit autotools
-do_install_append() {
+do_install:append() {
install -d ${D}/${sysconfdir}
install -d ${D}/${sysconfdir}/cron.d
install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/