aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-08-18 18:53:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:56:28 +0200
commit289217bbc3c5c53f486ab5615a6d6196e3c12cf2 (patch)
treef9551306e700a0ba0218177f3ec417f76d1f5759 /meta-networking/recipes-support/geoip
parentf2bec07b87b3f1118aa1d1f194d230920f1afe01 (diff)
downloadmeta-openembedded-contrib-289217bbc3c5c53f486ab5615a6d6196e3c12cf2.tar.gz
meta-oe: fix indentation
* remove tabs which sneaked in since last cleanup * meta-oe layers are using consistent indentation with 4 spaces, see http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip')
-rw-r--r--meta-networking/recipes-support/geoip/geoip-perl_1.45.bb10
-rw-r--r--meta-networking/recipes-support/geoip/geoip_1.6.9.bb45
2 files changed, 26 insertions, 29 deletions
diff --git a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
index 728ad5843d..fd3aae94b3 100644
--- a/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
+++ b/meta-networking/recipes-support/geoip/geoip-perl_1.45.bb
@@ -12,8 +12,8 @@ LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d"
# Note that we do not want to use the upstream file name locally.
#
SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz;downloadfilename=${BPN}-${PV}.tar.gz \
- file://run-ptest \
- "
+ file://run-ptest \
+"
SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2"
SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23"
@@ -30,10 +30,10 @@ EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
# perl scripts and some special small data files
#
do_install_ptest () {
- install -d -m 0755 ${D}${PTEST_PATH}/t/data
+ install -d -m 0755 ${D}${PTEST_PATH}/t/data
- install ${S}/t/*.t* ${D}${PTEST_PATH}/t
- install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
+ install ${S}/t/*.t* ${D}${PTEST_PATH}/t
+ install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
}
FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
diff --git a/meta-networking/recipes-support/geoip/geoip_1.6.9.bb b/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
index f46b3eb72d..9e8e0714f8 100644
--- a/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
+++ b/meta-networking/recipes-support/geoip/geoip_1.6.9.bb
@@ -62,32 +62,29 @@ RDEPENDS_${PN} += "${PN}-database"
inherit ptest
do_configure_ptest() {
- sed -i -e "s/noinst_PROGRAMS = /test_PROGRAMS = /g" \
- -e 's:SRCDIR=\\"$(top_srcdir)\\":SRCDIR=\\"$(testdir)\\":' \
- ${S}/test/Makefile.am
-
- if ! grep "^testdir = " ${S}/test/Makefile.am ; then
- sed -e '/EXTRA_PROGRAMS = /itestdir = ${PTEST_PATH}/tests' \
- -i ${S}/test/Makefile.am
- fi
-
- sed -i -e "s:/usr/local/share:/usr/share:g" \
- ${S}/test/benchmark.c
-
- sed -i -e 's:"../data/:"/usr/share/GeoIP/:g' \
- ${S}/test/test-geoip-city.c \
- ${S}/test/test-geoip-isp.c \
- ${S}/test/test-geoip-asnum.c \
- ${S}/test/test-geoip-netspeed.c \
- ${S}/test/test-geoip-org.c \
- ${S}/test/test-geoip-region.c
+ sed -i -e "s/noinst_PROGRAMS = /test_PROGRAMS = /g" \
+ -e 's:SRCDIR=\\"$(top_srcdir)\\":SRCDIR=\\"$(testdir)\\":' \
+ ${S}/test/Makefile.am
+
+ if ! grep "^testdir = " ${S}/test/Makefile.am ; then
+ sed -e '/EXTRA_PROGRAMS = /itestdir = ${PTEST_PATH}/tests' \
+ -i ${S}/test/Makefile.am
+ fi
+
+ sed -i -e "s:/usr/local/share:/usr/share:g" \
+ ${S}/test/benchmark.c
+
+ sed -i -e 's:"../data/:"/usr/share/GeoIP/:g' \
+ ${S}/test/test-geoip-city.c \
+ ${S}/test/test-geoip-isp.c \
+ ${S}/test/test-geoip-asnum.c \
+ ${S}/test/test-geoip-netspeed.c \
+ ${S}/test/test-geoip-org.c \
+ ${S}/test/test-geoip-region.c
}
do_install_ptest() {
- oe_runmake -C test DESTDIR=${D} install-testPROGRAMS
- install ${S}/test/*.txt ${D}${PTEST_PATH}/tests
+ oe_runmake -C test DESTDIR=${D} install-testPROGRAMS
+ install ${S}/test/*.txt ${D}${PTEST_PATH}/tests
}
-
-
-