aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
diff options
context:
space:
mode:
authorsusanbian <bianyq@cn.fujitsu.com>2017-06-26 09:35:22 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-06-28 10:29:52 -0400
commitc0083c77d059c3997a3fe6ea35b5f6ff0db6368d (patch)
treee3ae684656f11bfba62ab0ebefe0495d2a1b92f8 /meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
parentce91bef219313fbeb872e67a4cccc5ec2bd0d7a3 (diff)
downloadmeta-openembedded-contrib-c0083c77d059c3997a3fe6ea35b5f6ff0db6368d.tar.gz
geoipupdate 2.2.2 -> 2.4.0
Upgrade geoipupdate from 2.2.2 to 2.4.0 License checksum changed, since the following function are added. 1. database directory is writable 2. ${datarootdir}/GeoIP is now created on make install. 3. prints out additional information from the server when download reques results. Signed-off-by: susanbian <bianyq@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb')
-rw-r--r--meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb b/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
new file mode 100644
index 0000000000..3e045bb27d
--- /dev/null
+++ b/meta-networking/recipes-support/geoip/geoipupdate_2.4.0.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Crontab entry to provide weekly updates of the GeoIP free databases."
+DESCRIPTION = "update databases for GeoIP"
+
+HOMEPAGE = "http://dev.maxmind.com/geoip/"
+SECTION = "net"
+
+DEPENDS = "zlib curl"
+
+SRC_URI = "https://github.com/maxmind/geoipupdate/releases/download/v2.4.0/geoipupdate-2.4.0.tar.gz \
+ file://GeoIP.conf \
+ file://geoipupdate.cron \
+ "
+SRC_URI[md5sum] = "02f9712fb80e8e979d3d54cda7f7704f"
+SRC_URI[sha256sum] = "8b4e88ce8d84e9c75bc681704d19ec5c63c54f01e945f7669f97fb0df7e13952"
+
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "\
+file://ChangeLog.md;md5=334337b6ecbb65093bae66b3ae21c8c2 \
+"
+FILES_${PN} = "/usr/share/GeoIP \
+ /etc/GeoIP.conf \
+ /etc/cron.d/geoipupdate.cron \
+ /usr/bin/geoipupdate \
+"
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}
+ install -d ${D}/${sysconfdir}/cron.d
+ install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/
+ install ${WORKDIR}/geoipupdate.cron ${D}/${sysconfdir}/cron.d/
+}