aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/fetchmail
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-11-02 14:51:22 +0800
committerKhem Raj <raj.khem@gmail.com>2022-11-07 08:39:05 -0800
commit9497ca232586925dea248c913405470eb82528a7 (patch)
tree03f3e363c2896ca778007b7527442bdff6afa73a /meta-networking/recipes-support/fetchmail
parentad10d0d3b5fe64d7ecfdbe8eb8d9525539987419 (diff)
downloadmeta-openembedded-contrib-9497ca232586925dea248c913405470eb82528a7.tar.gz
fetchmail: Fix buildpaths warning.
WARNING: fetchmail-6.4.23-r0 do_package_qa: QA Issue: File /usr/bin/fetchmailconf in package fetchmail contains reference to TMPDIR [buildpaths] Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/fetchmail')
-rw-r--r--meta-networking/recipes-support/fetchmail/fetchmail_6.4.23.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/fetchmail/fetchmail_6.4.23.bb b/meta-networking/recipes-support/fetchmail/fetchmail_6.4.23.bb
index e4ad0a39e1..266573681e 100644
--- a/meta-networking/recipes-support/fetchmail/fetchmail_6.4.23.bb
+++ b/meta-networking/recipes-support/fetchmail/fetchmail_6.4.23.bb
@@ -18,5 +18,9 @@ inherit autotools gettext pkgconfig python3-dir python3native
EXTRA_OECONF = "--with-ssl=${STAGING_DIR_HOST}${prefix}"
+do_install:append() {
+ sed -i 's,${RECIPE_SYSROOT_NATIVE},,g' ${D}${bindir}/fetchmailconf
+}
+
PACKAGES =+ "fetchmail-python"
FILES:fetchmail-python = "${libdir}/${PYTHON_DIR}/*"