aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-02-05 13:40:45 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-22 17:04:43 -0700
commit6656d580c2cff33bc580f114f5e8ee8e07e3bd6f (patch)
tree4686592dbe243f8abe8ccbd3467aea506d87b557 /meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
parent16fc3c42c797113ff23395c6c24b56070687413e (diff)
downloadmeta-openembedded-contrib-6656d580c2cff33bc580f114f5e8ee8e07e3bd6f.tar.gz
drbd-utils: 8.9.6 -> 9.4.0
1.Upgrade drbd-utils from 8.9.6 to 9.4.0. 2.Delete 0001-Makefile.in-fix-permission-bits-for-drbd.service.patch, since it is integrated upstream. 3.Upgrade the SRC_URI to use git fetcher Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
new file mode 100644
index 0000000000..d6e913f00a
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Distributed block device driver for Linux"
+DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
+DRBD mirrors a block device over the network to another machine.\
+Think of it as networked raid 1. It is a building block for\
+setting up high availability (HA) clusters."
+HOMEPAGE = "http://www.drbd.org/"
+SECTION = "admin"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
+
+SRC_URI = "git://github.com/LINBIT/drbd-utils \
+ "
+# v9.4.0
+SRCREV = "eff6423ee72931aa0f8d0eb51742acee7c7cd3e1"
+
+S = "${WORKDIR}/git"
+
+UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
+
+SYSTEMD_SERVICE_${PN} = "drbd.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+inherit autotools-brokensep systemd
+
+EXTRA_OECONF = " \
+ --with-initdir=/etc/init.d \
+ --without-pacemaker \
+ --without-rgmanager \
+ --without-bashcompletion \
+ --with-distro debian \
+ --with-initscripttype=both \
+ --with-systemdunitdir=${systemd_unitdir}/system \
+ --without-manual\
+ "
+
+do_install_append() {
+ # don't install empty /var/lock to avoid conflict with base-files
+ rm -rf ${D}${localstatedir}/lock
+}
+
+RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
+
+# The drbd items are explicitly put under /lib when installed.
+#
+FILES_${PN} += "/run"
+FILES_${PN} += "${nonarch_base_libdir}/drbd \
+ ${nonarch_libdir}/drbd \
+ ${nonarch_libdir}/tmpfiles.d"
+FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"