aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
diff options
context:
space:
mode:
authorWang Xin <wangxin2015.fnst@cn.fujitsu.com>2016-09-14 00:51:57 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-15 11:01:54 -0500
commit8151702b66825504f9a5f076fd98d7538910830b (patch)
tree159b508d3425267e5fdb0c448d5b55e05bb6f2e3 /meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
parent598777d89d62eeb19dcf9b5b4c8939611facd1a4 (diff)
downloadmeta-openembedded-contrib-8151702b66825504f9a5f076fd98d7538910830b.tar.gz
drbd-utils: 8.9.3 -> 8.9.6
1) Upgrade drbd-utils from 8.9.3 to 8.9.6. 2) Delete one patch, since the data has been changed. 0001-Makefile.in-don-t-compile-documentation.patch 3) Modify EXTRA_OECONF, since the documentation file is not suitable for cross-compile, so we do not compile it. Signed-off-by: Wang Xin <wangxin2015.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
new file mode 100644
index 0000000000..3d6f5b2621
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils_8.9.6.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Distributed block device driver for Linux"
+DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
+DRBD mirrors a block device over the network to another machine.\
+Think of it as networked raid 1. It is a building block for\
+setting up high availability (HA) clusters."
+HOMEPAGE = "http://www.drbd.org/"
+SECTION = "admin"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
+
+SRC_URI = "http://oss.linbit.com/drbd/${BP}.tar.gz \
+ file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \
+ "
+SRC_URI[md5sum] = "76ed6d3190cd77b00890f3365353124b"
+SRC_URI[sha256sum] = "297b77c9b3f88de2e7dae459234f2753ea4fc2805282b2d276e35cf51e292913"
+
+SYSTEMD_SERVICE_${PN} = "drbd.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+inherit autotools-brokensep systemd
+
+EXTRA_OECONF = " \
+ --with-initdir=/etc/init.d \
+ --without-pacemaker \
+ --without-rgmanager \
+ --without-bashcompletion \
+ --with-distro debian \
+ --with-initscripttype=both \
+ --with-systemdunitdir=${systemd_unitdir}/system \
+ --without-manual\
+ "
+
+RDEPENDS_${PN} += "bash perl"
+
+# The drbd items are explicitly put under /lib when installed.
+#
+FILES_${PN} += "/run"
+FILES_${PN} += "${nonarch_base_libdir}/drbd \
+ ${nonarch_libdir}/drbd \
+ ${nonarch_libdir}/tmpfiles.d"
+FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"