aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-17 14:31:34 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:58 +0100
commit935eb8fa8dc9172965ed01eaf001548b1d510fc0 (patch)
tree18a21edfbd2c43fd3d7aa1789ed4917012f7ff4d /meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
parenta30ee70d8dbbec811a580f65af1adbaf1f1276af (diff)
downloadmeta-openembedded-contrib-935eb8fa8dc9172965ed01eaf001548b1d510fc0.tar.gz
dnssec-conf: Add new recipe
DNSSEC configuration and priming tool. Dnssec-conf includes a commandline configuration client for Bind and Unbound, known DNSSEC keys, URL's to official publication pages of keys, and harvested keys, as well a script to harvest DNSKEY's from DNS. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb')
-rw-r--r--meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb b/meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
new file mode 100644
index 0000000000..d915e0825c
--- /dev/null
+++ b/meta-networking/recipes-support/dnssec-conf/dnssec-conf_2.02.bb
@@ -0,0 +1,39 @@
+SUMMARY = "DNSSEC and DLV configuration and priming tool"
+DESCRIPTION = "\
+DNSSEC configuration and priming tool. Keys are required until the root \
+is signed, as well as for local unpublished DNSSEC keys to be preloaded \
+into the recursive nameserver. These DNSSEC configuration files can be \
+directly included in the bind or unbound nameserver configuration files. \
+dnssec-conf includes a commandline configuration client for Bind and \
+Unbound, known DNSSEC keys, URL's to official publication pages of keys, \
+and harvested keys, as well a script to harvest DNSKEY's from DNS. \
+See also: system-config-dnssec"
+HOMEPAGE = "https://github.com/xelerance/dnssec-conf"
+SECTION = "System Environment/Daemons"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+SRC_URI = "git://github.com/xelerance/dnssec-conf.git \
+ file://dnskey-pull.1 \
+ file://dnssec-configure.8"
+SRCREV = "8e799683736b4a7b5e5e78f98fba0a6f48393537"
+
+S = "${WORKDIR}/git"
+
+do_configure () {
+ sed -i '/^\sxmlto man/s=^=#=' Makefile
+}
+do_install () {
+ rm -rf ${D}
+ mv ${WORKDIR}/dnskey-pull.1 ${WORKDIR}/dnssec-configure.8 ${S}
+ make PREFIX=${prefix} DESTDIR=${D} ETCDIR=${D}${sysconfdir} install
+ # We no longer ship trust anchors. Most of these are in the DLV Registry now.
+ # and it prevents the problem of shipping outdated trust anchors.
+ # For DLV, we ship the ISC DLV Registry key
+ rm -rf ${D}${sysconfdir}/pki/dnssec-keys/harvest/*
+ rm -rf ${D}${sysconfdir}/pki/dnssec-keys/production/reverse/*
+ install -d -m 0755 ${D}${sysconfdir}/sysconfig
+ install -m 0644 packaging/fedora/dnssec.sysconfig ${D}${sysconfdir}/sysconfig/dnssec
+}
+
+RDEPENDS_${PN} = "python"