aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-03-22 00:35:11 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-03-24 14:10:18 -0400
commitf2dfae565531dd126131474b8a15dfe1d2871cc3 (patch)
treead57b363e423d7f75a0ce16625d6c2877d91ea79 /meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
parentcb3561aa22640e27d2bcadd541f247e90a7f1436 (diff)
downloadmeta-openembedded-contrib-f2dfae565531dd126131474b8a15dfe1d2871cc3.tar.gz
curlpp: 0.7.3 -> 0.8.1
Upgrade curlpp from 0.7.3 to 0.8.1. The main difference between 0.7.x and 0.8.0 is that it replaces autotools with cmake, see https://github.com/jpbarrette/curlpp/releases/tag/v0.8.0 The homepage of curlpp on googlecode is obsoleted, so update it and use soure code repo on github. Remove dependency boost which is dropped by upstream. And remove extra CXXFLAGS which has been fixed by upstream. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
new file mode 100644
index 0000000000..340f57dc7e
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "C++ library for client-side URL transfers"
+HOMEPAGE = "http://www.curlpp.org/"
+SECTION = "libdevel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+DEPENDS = "curl"
+DEPENDS_class-native = "curl-native"
+
+SRC_URI = "git://github.com/jpbarrette/curlpp.git"
+
+SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig binconfig
+
+do_install_append () {
+ sed -i 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/pkgconfig/curlpp.pc
+}
+
+PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
+
+FILES_lib${BPN} = "${libdir}/lib*.so.*"
+
+FILES_lib${BPN}-dev = "${includedir} \
+ ${libdir}/pkgconfig \
+ ${bindir}/*-config \
+"
+
+FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
+
+BBCLASSEXTEND = "native nativesdk"