aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/curlpp/curlpp
diff options
context:
space:
mode:
authorulf@emagii.com <ulf@emagii.com>2013-12-07 22:58:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-21 19:16:52 +0100
commita350707870735d5bcc694bacaaa0dfffb7233143 (patch)
tree02d484e6a777d31510fdf0c13eb4f7c170b1a3d3 /meta-networking/recipes-support/curlpp/curlpp
parentd3b37cd7af34adb3a546cb1741b79c4b77677b66 (diff)
downloadmeta-openembedded-contrib-a350707870735d5bcc694bacaaa0dfffb7233143.tar.gz
curlpp add package with c++ curl bindings
Signed-off-by: Ulf Samuelsson <ulf@emagii.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/curlpp/curlpp')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch b/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
new file mode 100644
index 0000000000..ad73c00885
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp/pkgconfig_fix.patch
@@ -0,0 +1,38 @@
+Upstream-Status: Inappropriate [packaging]
+
+
+Index: curl-7.20.0/libcurl.pc.in
+===================================================================
+--- curl-7.20.0.orig/libcurl.pc.in 2009-11-17 18:11:07.000000000 +0000
++++ curl-7.20.0/libcurl.pc.in 2010-03-25 12:13:26.814051066 +0000
+@@ -35,6 +35,7 @@
+ URL: http://curl.haxx.se/
+ Description: Library to transfer files with ftp, http, etc.
+ Version: @CURLVERSION@
+-Libs: -L${libdir} -lcurl @LIBS@
+-Libs.private: @LIBCURL_LIBS@ @LIBS@
++Requires.private: @GNUTLS_REQUIRED@
++Libs: -L${libdir} -lcurl
++Libs.private: -ldl -lz
+ Cflags: -I${includedir}
+Index: curl-7.20.0/configure.ac
+===================================================================
+--- curl-7.20.0.orig/configure.ac 2010-02-04 21:41:46.000000000 +0000
++++ curl-7.20.0/configure.ac 2010-03-25 12:12:18.673129001 +0000
+@@ -1668,6 +1668,7 @@
+ AC_SUBST(USE_GNUTLS, [1])
+ GNUTLS_ENABLED=1
+ USE_GNUTLS="yes"
++ GNUTLS_REQUIRED="gnutls"
+ curl_ssl_msg="enabled (GnuTLS)"
+ ],
+ [
+@@ -1696,6 +1697,8 @@
+
+ fi dnl OPENSSL != 1
+
++AC_SUBST(GNUTLS_REQUIRED)
++
+ dnl ----------------------------------------------------
+ dnl NSS. Only check if GnuTLS and OpenSSL are not enabled
+ dnl ----------------------------------------------------