aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
diff options
context:
space:
mode:
authorYao Xinpan <yaoxp@cn.fujitsu.com>2014-06-15 13:45:09 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-06-15 23:21:33 -0400
commite35a1fe480d3aa5cd0b0b8764f57796f3d7992d7 (patch)
tree946bc745d71c5f2b1279e1be9f179ce6a20c6705 /meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
parent8316933b400ae6fda688637fcc3e202b38a8e12b (diff)
downloadmeta-openembedded-contrib-e35a1fe480d3aa5cd0b0b8764f57796f3d7992d7.tar.gz
add recipe cim-schema, cim-schema-docs and license file DMTF.
Common Information Model (CIM) is a model for describing overall management information in a network or enterprise environment. CIM consists of a specification and a schema. The specification defines the details for integration with other management models. The schema provides the actual model descriptions. Signed-off-by: Yao Xinpan <yaoxp@cn.fujitsu.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb')
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
new file mode 100644
index 0000000000..06c0dd9858
--- /dev/null
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-docs_2.40.0.bb
@@ -0,0 +1,23 @@
+require cim-schema.inc
+
+LICENSE = "DMTF"
+
+SRC_URI = "http://dmtf.org/sites/default/files/cim/cim_schema_v2400/cim_schema_${PV}Final-Doc.zip \
+ file://LICENSE \
+ "
+SRC_URI[md5sum] = "3d01940bc1085c6c42184c25fb61f739"
+SRC_URI[sha256sum] = "3174cf0f8657b19d80dc59e184778d8e553da424728cb2966fe9d5428dd84267"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=eecc6f71a56ff3caf17f15bf7aeac7b4"
+
+do_unpack() {
+ unzip -q ${DL_DIR}/cim_schema_${PV}Final-Doc.zip -d ${S}
+ cp -f ${FILE_DIRNAME}/files/LICENSE ${WORKDIR}/
+}
+
+do_install() {
+ install -d -m 0755 ${D}${datadir}/doc/cim-schema-${PV}-docs
+ cp -a ${S}/* ${D}${datadir}/doc/cim-schema-${PV}-docs
+}
+
+FILES_${PN} = "${datadir}/doc/*"
+FILES_${PN}-doc = ""