aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-04 07:40:35 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-04 07:43:14 -0700
commitd04f3c9bfe62a9f77f64a49f9b54551827e5f192 (patch)
tree92626a8909939f0cd763e8649ff2ccd9610fbf98 /meta-networking/recipes-protocols
parent118bfa649324be52640ce52d69df0a6e06ab5ae7 (diff)
downloadmeta-openembedded-contrib-d04f3c9bfe62a9f77f64a49f9b54551827e5f192.tar.gz
mdns: Upgrade to 1310.140.1
Fix build with musl while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch41
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb (renamed from meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb)6
2 files changed, 44 insertions, 3 deletions
diff --git a/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch b/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch
new file mode 100644
index 0000000000..c743b3eddb
--- /dev/null
+++ b/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch
@@ -0,0 +1,41 @@
+From ea442b57f7a9bcd41d5b5bd1cafde4dbe5685d41 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 4 Nov 2021 07:31:32 -0700
+Subject: [PATCH] dns-sd: Include missing headers
+
+Fixes build on Musl
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Clients/dns-sd.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/Clients/dns-sd.c
++++ b/Clients/dns-sd.c
+@@ -58,11 +58,13 @@
+ //#define TEST_NEW_CLIENTSTUB 1
+
+ #include <ctype.h>
++#include <stdarg.h> // For va_args
+ #include <stdio.h> // For stdout, stderr
+ #include <stdlib.h> // For exit()
+ #include <string.h> // For strlen(), strcpy()
+ #include <errno.h> // For errno, EINTR
+ #include <time.h>
++#include <sys/param.h> // For MIN
+ #include <sys/types.h> // For u_char
+ #ifdef APPLE_OSX_mDNSResponder
+ #include <inttypes.h> // For PRId64
+--- a/mDNSPosix/nss_mdns.c
++++ b/mDNSPosix/nss_mdns.c
+@@ -89,6 +89,9 @@
+
+ #include <dns_sd.h>
+
++#if !defined(NETDB_INTERNAL)
++# define NETDB_INTERNAL (-1)
++#endif
+
+ //----------
+ // Public functions
diff --git a/meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
index c9bfef2d14..5c6d220200 100644
--- a/meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb
+++ b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
LICENSE = "Apache-2.0 & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
-COMPATIBLE_HOST:libc-musl = 'null'
+DEPENDS:append:libc-musl = " musl-nscd"
RPROVIDES:${PN} += "libdns_sd.so"
@@ -21,9 +21,9 @@ SRC_URI = "https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${P
file://0009-Fix-possible-NULL-dereference.patch;patchdir=.. \
file://0010-Handle-errors-from-socket-calls.patch;patchdir=.. \
file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch;patchdir=.. \
+ file://0001-dns-sd-Include-missing-headers.patch;patchdir=.. \
"
-SRC_URI[md5sum] = "dfcfd4d7f29a56ec99e7df1d21db5e7b"
-SRC_URI[sha256sum] = "bea29e1616cd56ccb8f88c0fad2bcdc4031f4deb2d899c793e2f27a8384f0b34"
+SRC_URI[sha256sum] = "040f6495c18b9f0557bcf9e00cbcfc82b03405f5ba6963dc147730ca0ca90d6f"
CVE_PRODUCT = "apple:mdnsresponder"