aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:29 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-11-14 10:07:27 -0500
commitdce441f95ea37356b10dfa03de794925d82089b0 (patch)
tree3f93e9b6f298684e721634815ec6173fa5d1b663 /meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
parentaebf681a9e7cf6b6018892e05f53a6c5806e6e2f (diff)
downloadmeta-openembedded-contrib-dce441f95ea37356b10dfa03de794925d82089b0.tar.gz
openl2tp: Fix build with clang
Fix a typo in compile cmdline specified via EXTRA_OECMAKE Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb')
-rw-r--r--meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
index 270472efba..5a63404867 100644
--- a/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
+++ b/meta-networking/recipes-protocols/openl2tp/openl2tp_1.8.bb
@@ -15,14 +15,15 @@ SRC_URI = "http://ftp.jaist.ac.jp/pub/sourceforge/o/op/${PN}/${PN}/${PV}/${BP}.t
file://Makefile-modify-CFLAGS-to-aviod-build-error.patch \
file://openl2tp-simplify-gcc-warning-hack.patch \
file://Makefile-obey-LDFLAGS.patch \
- "
+ file://0001-test-pppd_dummy.c-Fix-return-value.patch \
+ "
SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0"
SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f"
inherit autotools-brokensep pkgconfig
PARALLEL_MAKE = ""
-EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-nused-but-set-variable"'
+EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-unused-but-set-variable"'
do_compile_prepend() {
sed -i -e "s:SYS_LIBDIR=.*:SYS_LIBDIR=${libdir}:g" \