aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-12-31 17:03:30 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-05 09:15:59 -0800
commit5816f414affba9557fd94475fdb4aeb5715ef72f (patch)
tree9bb4386380951f140358dec5c3eaddcb1403a13f /meta-networking/recipes-filter
parentcac0daacd102fa30359c13ca76e3eac0e58c5c21 (diff)
downloadmeta-openembedded-contrib-5816f414affba9557fd94475fdb4aeb5715ef72f.tar.gz
ebtables: remove upstream ebtables-legacy-save
Remove the upstream ebtables-legacy-save before we install the local ones. And install it to ${sbindir} rather than ${base_sbindir}. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-filter')
-rw-r--r--[-rwxr-xr-x]meta-networking/recipes-filter/ebtables/ebtables-2.0.11/ebtables-legacy-save2
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/ebtables-legacy-save b/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/ebtables-legacy-save
index 2d7fc4ed7c..2133600f77 100755..100644
--- a/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/ebtables-legacy-save
+++ b/meta-networking/recipes-filter/ebtables/ebtables-2.0.11/ebtables-legacy-save
@@ -1,6 +1,6 @@
#!/bin/bash
-EBTABLES="/sbin/ebtables"
+EBTABLES="/usr/sbin/ebtables-legacy"
[ -x "$EBTABLES" ] || exit 1
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
index 08d4d661d8..be21c372d9 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
@@ -28,11 +28,11 @@ do_install_append () {
#This file has been provided by netbase
rm -f ${D}${sysconfdir}/ethertypes
- install -d ${D}${base_sbindir}
# Replace upstream ebtables-save perl script with Fedora bash based rewrite
# http://pkgs.fedoraproject.org/cgit/rpms/ebtables.git/tree/ebtables-save
- install -m 0755 ${WORKDIR}/ebtables-legacy-save ${D}${base_sbindir}/ebtables-legacy-save
- sed -i 's!/sbin/!${base_sbindir}/!g' ${D}${base_sbindir}/ebtables-legacy-save
+ rm -f ${D}${sbindir}/ebtables-legacy-save
+ install -m 0755 ${WORKDIR}/ebtables-legacy-save ${D}${sbindir}/ebtables-legacy-save
+
# Install systemd service files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_unitdir}/system