aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
diff options
context:
space:
mode:
authorJan Kaisrlik <jan.kaisrlik@avast.com>2018-10-10 15:54:57 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-10 08:53:21 -0700
commitf72160a3dc1ee7e8c0edfb19cfdb4b6a7fa3ab2b (patch)
tree0de0c9e6800e50fdcd67f909ef047f6c9793d7ba /meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
parent1b68e3eb582102ef2327fd90bfed6f32b54c2791 (diff)
downloadmeta-openembedded-contrib-f72160a3dc1ee7e8c0edfb19cfdb4b6a7fa3ab2b.tar.gz
grpc: fix grpc_cpp_plugin interpfor nativesdk
When building grpc for nativesdk the project tries to execute the nativesdk grpc_cpp_plugin instead of the host one. Apply the patch fixing the cross-compilation for nativesdk build and modify its contents to reflect its new purpose. Also: add grpc-native to dependencies. Signed-off-by: Hiram Lew <lew@avast.com> Signed-off-by: Jan Kaisrlik <jan.kaisrlik@avast.com> Signed-off-by: Lukas Karas <karas@avast.com> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb')
-rw-r--r--meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb b/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
index 7b3f73657c..d236714325 100644
--- a/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
+++ b/meta-networking/recipes-devtools/grpc/grpc_1.14.1.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl"
DEPENDS_append_class-target = " gtest grpc-native "
+DEPENDS_append_class-nativesdk = " grpc-native "
S = "${WORKDIR}/git"
SRCREV = "d8020cb6daa87f1a3bb3b0c299bc081c4a3de1e8"
@@ -16,6 +17,7 @@ SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;branch=${BRANCH} \
file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \
"
SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
+SRC_URI_append_class-nativesdk = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
# Fixes build with older compilers 4.8 especially on ubuntu 14.04
CXXFLAGS_append_class-native = " -Wl,--no-as-needed"