aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorJ.D. Schroeder <sweng5080@gmail.com>2023-08-03 12:16:18 -0500
committerArmin Kuster <akuster808@gmail.com>2023-08-03 16:50:52 -0400
commita7a66cdb13accf0e78a1b3d31ef8770ecdcee3f9 (patch)
tree80d16e4bed408115844ce6c008de113ac08461a6 /meta-networking/recipes-daemons
parentcb8053362566f1ce17b25c34a1337f6410ebe214 (diff)
downloadmeta-openembedded-contrib-a7a66cdb13accf0e78a1b3d31ef8770ecdcee3f9.tar.gz
Fix groupname gid change warning
This patch fixes warnings when useradd-staticids.bbclass is used and USERADD_PARAM is used to add the user to a group that has not been explicitly created yet. By adding the GROUPADD_PARAM for the new group being used the warnings for changing the gid from GID-OLD to GID-NEW is eliminated. Warnings fixed: cyrus-sasl: Changing groupname mail's gid from (WXYZ) to (JKLM), verify configuration files! radvd: Changing groupname nogroup's gid from (WXYZ) to (JKLM), verify configuration files! Signed-off-by: JD Schroeder <sweng5080@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb1
-rw-r--r--meta-networking/recipes-daemons/radvd/radvd.inc1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb
index e344733ef4..3fc1b0fd17 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb
@@ -73,6 +73,7 @@ do_install:append() {
}
USERADD_PACKAGES = "${PN}-bin"
+GROUPADD_PARAM:${PN}-bin = "--system mail"
USERADD_PARAM:${PN}-bin = "--system --home=/var/spool/mail -g mail cyrus"
SYSTEMD_PACKAGES = "${PN}-bin"
diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc b/meta-networking/recipes-daemons/radvd/radvd.inc
index 2afaa48411..219d88f499 100644
--- a/meta-networking/recipes-daemons/radvd/radvd.inc
+++ b/meta-networking/recipes-daemons/radvd/radvd.inc
@@ -58,6 +58,7 @@ do_install:append () {
}
USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM:${PN} = "--system nogroup"
USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup radvd"
pkg_postinst:${PN} () {