aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2014-09-15 16:43:51 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2014-09-23 21:59:56 -0400
commit2fab4b8902320d0323e3a59ea72e743f24eb36c9 (patch)
tree397a01aa25fc1c12df48f4a000aa74e90389aa05 /meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch
parentf2715a565228a50cb9da1102d2758937addf21e3 (diff)
downloadmeta-openembedded-contrib-2fab4b8902320d0323e3a59ea72e743f24eb36c9.tar.gz
vftpd: update to version 3.0.2
No changes other than source checksum. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch
new file mode 100644
index 0000000000..9a10f722f4
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.2/makefile-libs.patch
@@ -0,0 +1,21 @@
+Hardcode LIBS instead of using a script to determine available libs
+
+We want to avoid this dynamic detection so we have a deterministic
+build.
+
+Upstream-Status: Inappropriate [config]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/Makefile b/Makefile
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@
+ #CFLAGS = -g
+ CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
+
+-LIBS = `./vsf_findlibs.sh`
++LIBS = -lssl -lcrypto -lnsl -lresolv
+ LINK = -Wl,-s
+
+ OBJS = main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o \