aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
index a971677203..caa85e040a 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
@@ -37,10 +37,10 @@ UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/opensaf/files/releases"
inherit autotools useradd systemd pkgconfig
USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "-f -r opensaf"
-USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
+GROUPADD_PARAM:${PN} = "-f -r opensaf"
+USERADD_PARAM:${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
-SYSTEMD_SERVICE_${PN} += "opensafd.service"
+SYSTEMD_SERVICE:${PN} += "opensafd.service"
SYSTEMD_AUTO_ENABLE = "disable"
PACKAGECONFIG[systemd] = ",,systemd"
@@ -53,7 +53,7 @@ CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
-do_install_append() {
+do_install:append() {
rm -fr "${D}${localstatedir}/lock"
rm -fr "${D}${localstatedir}/run"
rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
@@ -64,15 +64,15 @@ do_install_append() {
fi
}
-FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
-FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
-FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
+FILES:${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
+FILES:${PN}-dev += "${libdir}/libopensaf_core.so"
+FILES:${PN}-staticdev += "${PKGLIBDIR}/*.a"
-INSANE_SKIP_${PN} = "dev-so"
+INSANE_SKIP:${PN} = "dev-so"
-RDEPENDS_${PN} += "bash python3-core"
+RDEPENDS:${PN} += "bash python3-core"
# http://errors.yoctoproject.org/Errors/Details/186970/
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'
FILES_SOLIBSDEV = ""