aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorJack Mitchell <ml@embed.me.uk>2020-08-25 09:56:21 +0100
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:39:27 -0700
commitaf306b7f7f53cd8574d095effdea9fae5b303d38 (patch)
tree380ccba586534bb346b7e9c01008fb88e8a42b62 /meta-networking/recipes-connectivity
parent4c7f8a09976f4b815500a2a68e1b2ca6434a25fa (diff)
downloadmeta-openembedded-contrib-af306b7f7f53cd8574d095effdea9fae5b303d38.tar.gz
meta-networking: dhcpcd: backport ALIGN compile error fix
Fails to build on an aarch64 system with ipv6 disabled. This backported patch fixes it. Signed-off-by: Jack Mitchell <ml@embed.me.uk> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb3
-rw-r--r--meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch34
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb b/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb
index defd3420f0..766df3a2b0 100644
--- a/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb
+++ b/meta-networking/recipes-connectivity/dhcpcd/dhcpcd_9.1.4.bb
@@ -12,7 +12,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
SRC_URI = "http://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
- file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch"
+ file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
+ file://0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch"
SRC_URI[sha256sum] = "5fe133e5497d8af6d26bd6e6b8dd48ab12d124d6cc4cefe6de6536ff97f76820"
diff --git a/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch b/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch
new file mode 100644
index 0000000000..2c7f24ebfa
--- /dev/null
+++ b/meta-networking/recipes-connectivity/dhcpcd/files/0002-Fix-compile-without-IPv6-on-systems-that-do-not-define-ALIGN.patch
@@ -0,0 +1,34 @@
+From 7643b6615aab4de290ead6c1a6b56f10a82bbe6f Mon Sep 17 00:00:00 2001
+From: Roy Marples <roy@marples.name>
+Date: Sat, 4 Jul 2020 13:21:09 +0100
+Subject: [PATCH] Fix compile without IPv6 on systems that do not define ALIGN
+
+Upstream-Status: backport
+
+---
+ src/dhcpcd.h | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/src/dhcpcd.h b/src/dhcpcd.h
+index 61a6a081..d9719c0a 100644
+--- a/src/dhcpcd.h
++++ b/src/dhcpcd.h
+@@ -96,7 +96,6 @@ TAILQ_HEAD(if_head, interface);
+
+ #include "privsep.h"
+
+-#ifdef INET6
+ /* dhcpcd requires CMSG_SPACE to evaluate to a compile time constant. */
+ #if defined(__QNX) || \
+ (defined(__NetBSD_Version__) && __NetBSD_Version__ < 600000000)
+@@ -113,10 +112,6 @@ TAILQ_HEAD(if_head, interface);
+ #define CMSG_SPACE(len) (ALIGN(sizeof(struct cmsghdr)) + ALIGN(len))
+ #endif
+
+-#define IP6BUFLEN (CMSG_SPACE(sizeof(struct in6_pktinfo)) + \
+- CMSG_SPACE(sizeof(int)))
+-#endif
+-
+ struct passwd;
+
+ struct dhcpcd_ctx {