aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-01-17 17:26:26 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-20 10:15:44 -0800
commite6836ceaef005cb870bea43635833cc92aa3a68d (patch)
tree44fe2221605d7e47cd189076618d58d62232dc49 /meta-networking/recipes-connectivity
parent97a1a55f475510569590f9b8ad2786bdb34f0319 (diff)
downloadmeta-openembedded-contrib-e6836ceaef005cb870bea43635833cc92aa3a68d.tar.gz
networkmanager: introduce polkit package config
Currently polkit is enabled if systemd is in package config. Those two things are orthogonal: NetworkManager can be used with systemd and without polkit just fine. Introduce a new polkit package config and enable it depending on whether polkit is in DISTRO_FEATURES. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
index 870a528147..f1826c68e1 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
@@ -16,7 +16,6 @@ DEPENDS = " \
util-linux \
libndp \
libnewt \
- polkit \
jansson \
curl \
"
@@ -69,13 +68,13 @@ do_compile_prepend() {
PACKAGECONFIG ??= "nss ifupdown dhclient dnsmasq \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \
- ${@bb.utils.filter('DISTRO_FEATURES', 'wifi', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'wifi polkit', d)} \
"
PACKAGECONFIG[systemd] = " \
- --with-systemdsystemunitdir=${systemd_unitdir}/system --with-session-tracking=systemd --enable-polkit, \
+ --with-systemdsystemunitdir=${systemd_unitdir}/system --with-session-tracking=systemd, \
--without-systemdsystemunitdir, \
- polkit \
"
+PACKAGECONFIG[polkit] = "--enable-polkit --enable-polkit-agent,--disable-polkit --disable-polkit-agent,polkit"
PACKAGECONFIG[bluez5] = "--enable-bluez5-dun,--disable-bluez5-dun,bluez5"
# consolekit is not picked by shlibs, so add it to RDEPENDS too
PACKAGECONFIG[consolekit] = "--with-session-tracking=consolekit,,consolekit,consolekit"