aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-13 10:55:11 +0000
committerKhem Raj <raj.khem@gmail.com>2019-01-13 10:28:01 -0800
commit24af1f974cc95c50dfa56ad15b113279c3993c5d (patch)
tree40a09c3734718cf88b34e4c3b991ae11360fdee8 /meta-networking/recipes-connectivity
parent88f2b979caf24fad736b8e378cf9daa142ae0567 (diff)
downloadmeta-openembedded-contrib-24af1f974cc95c50dfa56ad15b113279c3993c5d.tar.gz
meta-networking: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple attempts at doing so (or simply have re-appeared?). Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb2
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.8.4.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
index 01562aad16..8f406ff9ca 100644
--- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
+++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.4.bb
@@ -39,7 +39,7 @@ EXTRA_OEMAKE = " \
WITH_BUNDLED_DEPS=no \
"
-export LIB_SUFFIX = "${@d.getVar('baselib', True).replace('lib', '')}"
+export LIB_SUFFIX = "${@d.getVar('baselib').replace('lib', '')}"
do_install() {
oe_runmake 'DESTDIR=${D}' install
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
index f1aaeb83d9..e86ed96a5d 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb
@@ -193,15 +193,15 @@ PACKAGES =+ "${PN}-python ${PN}-pidl \
python samba_populate_packages() {
def module_hook(file, pkg, pattern, format, basename):
- pn = d.getVar('PN', True)
+ pn = d.getVar('PN')
d.appendVar('RRECOMMENDS_%s-base' % pn, ' %s' % pkg)
- mlprefix = d.getVar('MLPREFIX', True) or ''
+ mlprefix = d.getVar('MLPREFIX') or ''
pam_libdir = d.expand('${base_libdir}/security')
pam_pkgname = mlprefix + 'pam-plugin%s'
do_split_packages(d, pam_libdir, '^pam_(.*)\.so$', pam_pkgname, 'PAM plugin for %s', extra_depends='', prepend=True)
- libdir = d.getVar('libdir', True)
+ libdir = d.getVar('libdir')
do_split_packages(d, libdir, '^lib(.*)\.so\..*$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True, allow_links=True)
pkglibdir = '%s/samba' % libdir
do_split_packages(d, pkglibdir, '^lib(.*)\.so$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True)