aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/snort
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-07-19 16:30:38 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:06:50 -0400
commit3683e46e050906a58c5507a9aa51458bf36c4d7c (patch)
tree61fd0503a0e8f5fe3808496bb71496699b4591c6 /meta-networking/recipes-connectivity/snort
parentb2eae93d0ac9ea8e4c96687a3908242a718b4214 (diff)
downloadmeta-openembedded-contrib-3683e46e050906a58c5507a9aa51458bf36c4d7c.tar.gz
snort: fix to remove from blacklist
Fix paths in pkgconfig files and remove snort from blacklist. Also add 'xz' to DEPENDS to avoid the following QA issue. WARNING: snort-2.9.7.5-r0 do_package_qa: QA Issue: snort rdepends on liblzma, but it isn't a build dependency, missing xz in DEPENDS or PACKAGECONFIG? [build-deps] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/snort')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort_2.9.7.5.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.7.5.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.7.5.bb
index 7d946af25b..fb717993cd 100644
--- a/meta-networking/recipes-connectivity/snort/snort_2.9.7.5.bb
+++ b/meta-networking/recipes-connectivity/snort/snort_2.9.7.5.bb
@@ -4,7 +4,7 @@ SECTION = "net"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=78fa8ef966b48fbf9095e13cc92377c5"
-DEPENDS = "libpcap libpcre daq libdnet util-linux"
+DEPENDS = "xz libpcap libpcre daq libdnet util-linux"
SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \
file://snort.init \
@@ -56,6 +56,8 @@ do_install_append() {
install -m 755 ${WORKDIR}/snort.init ${D}${sysconfdir}/init.d/snort
mkdir -p ${D}${localstatedir}/log/snort
install -d ${D}/var/log/snort
+
+ sed -i 's/-fdebug-prefix-map[^ ]*//g; s#${STAGING_DIR_TARGET}##g' ${D}${libdir}/pkgconfig/*.pc
}
FILES_${PN} += " \
@@ -84,6 +86,3 @@ FILES_${PN}-dev += " \
${libdir}/snort_dynamicrules/*.so \
${prefix}/src/snort_dynamicsrc \
"
-
-# http://errors.yoctoproject.org/Errors/Details/35137/
-PNBLACKLIST[snort] ?= "BROKEN: QA Issue: snort_preproc.pc, snort_output.pc, snort.pc"