aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-22 18:40:52 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2018-04-25 15:53:45 -0400
commit575c14ded56e1e97582a6df0921d19b4da630961 (patch)
treebf07f4af9a0c316776926e5b0e7db28ef362ef06 /meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb
parentf0a664f2b7ac42fa8832ecc016ddf8b6260ee50e (diff)
downloadmeta-openembedded-contrib-575c14ded56e1e97582a6df0921d19b4da630961.tar.gz
networkmanager: fix gobject-introspection/musl and cleanup
This adresses the comments for recent patch which updated nm to 1.10.6 and is a follow-up for [1]. * Make gobject-introspection work by skipping creation of gobject-introspection specific documentation. This fixes networkmanager-applet regression. * Cleanup patches: Remove current musl patches completely and re-use those found in void-linux because they do look much cleaner and don't touch glibc build. One nice side effect: In the future when nm is updated we can steal again and don't need to reenvent here. Usually they are much faster than we are (and I know one major contibutor personally from the good old Z80 times..) * Fix typo in PACKAGECONFIG [1] https://patchwork.openembedded.org/patch/149244/ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb')
-rw-r--r--meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb33
1 files changed, 18 insertions, 15 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb
index 6538e7b823..f201a75a0a 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.10.6.bb
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=cbbffd568227ada506640fe950a4823b \
DEPENDS = " \
intltool-native \
+ libxslt-native \
libnl \
dbus \
dbus-glib \
@@ -23,18 +24,18 @@ DEPENDS = " \
curl \
"
-inherit gnomebase gettext systemd bluetooth bash-completion vala gobject-introspection
-
-GI_DATA_ENABLED_libc-musl = "False"
-
-SRC_URI = "${GNOME_MIRROR}/NetworkManager/${@gnome_verdir("${PV}")}/NetworkManager-${PV}.tar.xz \
- file://0001-adjust-net-headers-for-musl-compatibility.patch \
- file://0002-socket-util.h-Include-linux-sockios.h-on-musl.patch \
- file://0003-Define-ETH_ALEN.patch \
- file://0005-sd-lldp.h-Remove-net-ethernet.h-seems-to-be-over-spe.patch \
- file://0006-check-for-strndupa-before-using-it.patch \
- file://0007-Fixed-configure.ac-Fix-pkgconfig-sysroot-locations.patch \
- "
+inherit gnomebase gettext systemd bluetooth bash-completion vala gobject-introspection gtk-doc
+
+SRC_URI = " \
+ ${GNOME_MIRROR}/NetworkManager/${@gnome_verdir("${PV}")}/NetworkManager-${PV}.tar.xz \
+ file://0001-sd-lldp.h-Remove-net-ethernet.h-seems-to-be-over-spe.patch \
+ file://0002-Fixed-configure.ac-Fix-pkgconfig-sysroot-locations.patch \
+ file://0003-Do-not-create-settings-settings-property-documentati.patch \
+ file://musl/0001-musl-basic.patch \
+ file://musl/0002-musl-dlopen-configure-ac.patch \
+ file://musl/0003-musl-network-support.patch \
+ file://musl/0004-musl-process-util.patch \
+"
SRC_URI[md5sum] = "de3c7147a693da6f80eb22f126086a14"
SRC_URI[sha256sum] = "6af0b1e856a3725f88791f55c4fbb04105dc0b20dbf182aaec8aad16481fac76"
@@ -44,20 +45,22 @@ EXTRA_OECONF = " \
--disable-ifcfg-rh \
--disable-ifnet \
--disable-ifcfg-suse \
- --disable-introspection \
--disable-more-warnings \
--with-iptables=${sbindir}/iptables \
--with-tests \
--with-nmtui=yes \
"
+# gobject-introspection related
+GI_DATA_ENABLED_libc-musl = "False"
+
do_compile_prepend() {
- export GIR_EXTRA_LIBS_PATH="${B}/libnm-util/.libs"
+ export GIR_EXTRA_LIBS_PATH="${B}/libnm/.libs:${B}/libnm-glib/.libs:${B}/libnm-util/.libs"
}
PACKAGECONFIG ??= "nss ifupdown netconfig dhclient dnsmasq \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', \
- bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'consolekit', '', d), d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)} \
${@bb.utils.filter('DISTRO_FEATURES', 'wifi', d)} \
"