aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-11-27 09:55:54 +0800
committerKhem Raj <raj.khem@gmail.com>2020-11-27 14:21:57 -0800
commit9ef0c70871c86d5b5a0e5248eb019c701b0572b5 (patch)
tree5abb2d02c0bc7b109bd21145333bff50e966b657 /meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
parentd9874ce27c7a2ff3ed2a3a2e5f6de810f10421ae (diff)
downloadmeta-openembedded-contrib-9ef0c70871c86d5b5a0e5248eb019c701b0572b5.tar.gz
netplan: upgrade 0.99 -> 0.100
0001-src-parse.c-Initialize-key-to-NULL.patch Removed since this is included in 0.100. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch')
-rw-r--r--meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch b/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
new file mode 100644
index 0000000000..cd75d1cb1c
--- /dev/null
+++ b/meta-networking/recipes-connectivity/netplan/netplan/0002-Makefile-Exclude-.h-files-from-target-rule.patch
@@ -0,0 +1,30 @@
+From 5abb6b8343b5d2633844144979b40f398450b544 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 27 Nov 2020 12:22:32 -0800
+Subject: [PATCH 2/2] Makefile: Exclude .h files from target rule
+
+This ensures that src/_features.h is not added to compiler cmdline which
+can confuse the compilers e.g. clang as it may not like .h as valid input
+and complain
+
+| clang-11: error: cannot specify -o when generating multiple output files
+| make: *** [Makefile:50: netplan-dbus] Error 1
+| make: *** Waiting for unfinished jobs....
+
+Upstream-Status: Submitted [https://github.com/CanonicalLtd/netplan/pull/175]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Makefile
++++ b/Makefile
+@@ -47,7 +47,7 @@ generate: libnetplan.so.$(NETPLAN_SOVER)
+ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^ -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
+
+ netplan-dbus: src/dbus.c src/_features.h
+- $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $^ `pkg-config --cflags --libs libsystemd glib-2.0`
++ $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(patsubst %.h,,$^) `pkg-config --cflags --libs libsystemd glib-2.0`
+
+ src/_features.h: src/[^_]*.[hc]
+ printf "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {\n" > $@