aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/mbedtls
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-05-26 09:24:44 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-06-05 22:18:30 -0400
commit01ffc1f2b28b2202187f041664e0c5e18064774c (patch)
treebb57ba71eed0a4ac59bbb42019298e8694f71dee /meta-networking/recipes-connectivity/mbedtls
parent77d9d68c131d386b37d6d33a4f1601c1ecf400c5 (diff)
downloadmeta-openembedded-contrib-01ffc1f2b28b2202187f041664e0c5e18064774c.tar.gz
mbedtls: upgrade to 1.3.10
1. PolarSSL is now rebranded as mbed TLS. 2. upgrade to include CVE-2015-1182 fix: http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-1182 Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb
new file mode 100644
index 0000000000..d5c7afe04f
--- /dev/null
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Lightweight crypto and SSL/TLS library"
+DESCRIPTION = "mbedtls is a lean open source crypto library \
+for providing SSL and TLS support in your programs. It offers \
+an intuitive API and documented header files, so you can actually \
+understand what the code does. It features: \
+ \
+ - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
+ Camellia and XTEA \
+ - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
+ - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
+ - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
+ ECDSA and ECDH \
+ - SSL v3 and TLS 1.0, 1.1 and 1.2 \
+ - Abstraction layers for ciphers, hashes, public key operations, \
+ platform abstraction and threading \
+"
+
+HOMEPAGE = "https://polarssl.org"
+BUGTRACKER = "https://github.com/polarssl/polarssl/issues"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SECTION = "libdevel"
+
+SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-gpl.tgz"
+
+SRC_URI[md5sum] = "19ebbc96feceb430ad958dfe89cb633f"
+SRC_URI[sha256sum] = "746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e"
+
+DEPENDS = "openssl"
+RDEPENDS_${PN} += "libcrypto"
+PROVIDES += "polarssl"
+RPROVIDES_${PN} = "polarssl"
+EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on -DLIB_INSTALL_DIR=${baselib}"
+
+inherit cmake