aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-26 10:00:03 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-18 12:30:56 -0700
commit95c5fbffecfcdcf97531b0b662806801f06c944e (patch)
tree14e1820a63c2bf5536ef5bffcd2540d4de11e9de /meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb
parentce6ed2ec854316bd6527535ee68f05ea93ea484b (diff)
downloadmeta-openembedded-contrib-95c5fbffecfcdcf97531b0b662806801f06c944e.tar.gz
lftp: Upgrade to 4.8.3
Drop libidn packageconfig, this is no more an option in configure.ac Package the icon files Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb')
-rw-r--r--meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb b/meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb
new file mode 100644
index 0000000000..08d89b8c56
--- /dev/null
+++ b/meta-networking/recipes-connectivity/lftp/lftp_4.8.3.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "LFTP is a sophisticated file transfer program with \
+ command line interface. It supports FTP, HTTP, \
+ FISH, SFTP, HTTPS and FTPS protocols"
+HOMEPAGE = "http://lftp.yar.ru/"
+SECTION = "console/network"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI = "http://lftp.yar.ru/ftp/lftp-${PV}.tar.bz2 \
+ file://fix-gcc-6-conflicts-signbit.patch \
+ "
+SRC_URI[md5sum] = "12b1fcbf13f41e9cdb0903fc670fa1f1"
+SRC_URI[sha256sum] = "c4159f056afee41866a6c2d639655bc351e6d3486bbe7758eaedb24f6a4239d5"
+
+inherit autotools gettext pkgconfig
+
+acpaths = "-I ./m4"
+
+EXTRA_OECONF += "--with-modules"
+
+PACKAGECONFIG ??= "openssl zlib gnutls readline expat"
+PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
+PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_INCDIR}/.., --without-zlib, zlib"
+PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls"
+PACKAGECONFIG[readline] = "--with-readline=${STAGING_INCDIR}/.. --with-readline-inc=${STAGING_INCDIR} --with-readline-lib=-lreadline, --with-readline=no, readline"
+PACKAGECONFIG[expat] = "--with-expat=${STAGING_INCDIR}/.. --with-expat-inc=${STAGING_INCDIR} --with-expat-lib=-lexpat, , expat"
+
+do_install_append() {
+ rm -rf ${D}${libdir}/charset.alias
+}
+FILES_${PN} += "${datadir}/icons/hicolor"
+FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug"
+RDEPENDS_${PN} = "perl bash readline"