aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
diff options
context:
space:
mode:
authorchunrong guo <b40290@freescale.com>2012-11-20 07:10:37 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-11-27 14:43:58 -0500
commit11a6ce97f710fe6578a92edc5409b0aa315da79f (patch)
tree6ad2b7bc3c56c13a5296ac617dfa9909f07d095c /meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
parenteb63724f431a0fb6b2fec1bd84ae7f04cb8744df (diff)
downloadmeta-openembedded-contrib-11a6ce97f710fe6578a92edc5409b0aa315da79f.tar.gz
inetutils : Update to 1.9.1
* There are difference spaces between inetutils-1.8/COPYING and inetutils-1.9.1/COPYING,so md5sum is changed. * the following patches are accepted by inetutils 1.9.1 upstream inetutils-1.8-1005-ftpd-add-daemon-D-nommu-support.patch inetutils-1.8-1004-detect-fork-support.patch inetutils-1.8-1003-use-daemon-from-the-C-library-when-possible.patch inetutils-1.8-1002-rshd-detect-__rcmd_errstr-support-in-the-C-lib.patch inetutils-1.8-1001-ftp-rename-ruserpass-to-avoid-C-library-collision.patch inetutils-1.8-0002-argp-fix-program_invocation_name-detection.patch Signed-off-by: Chunrong Guo <b40290@freescale.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb')
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
new file mode 100644
index 0000000000..81457d7d66
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "The GNU inetutils are a collection of common \
+networking utilities and servers including ftp, ftpd, rcp, \
+rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
+talkd, telnet, telnetd, tftp, tftpd, and uucpd."
+SECTION = "libs"
+DEPENDS = "ncurses"
+LICENSE = "GPLv3"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7"
+
+
+SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
+ file://disable-pre-ANSI-compilers.patch \
+ file://version.patch \
+ file://remove-gets.patch \
+ file://inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch \
+ file://inetutils-1.8-0003-wchar.patch \
+ file://fix-disable-ipv6.patch \
+"
+SRC_URI[md5sum] = "944f7196a2b3dba2d400e9088576000c"
+SRC_URI[sha256sum] = "02a9ebde8a198cb85f87545b9d88fb103a183958139864a85fe9e027ad79ff2b"
+
+inherit autotools gettext
+
+noipv6="${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6 gl_cv_socket_ipv6=no', d)}"
+EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \
+ --with-path-procnet-dev=/proc/net/dev \
+ ${noipv6} \
+ "
+
+do_configure_prepend () {
+ export HELP2MAN='true'
+ cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
+ rm -f ${S}/glob/configure*
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_sbindir} ${D}${base_bindir}
+ mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
+ mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
+ mv ${D}${bindir}/logger ${D}${bindir}/logger.${PN}
+ mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${PN}
+ mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
+ mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/tftp tftp tftp.${PN} 100
+ update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
+ update-alternatives --install ${bindir}/logger logger logger.${PN} 100
+ update-alternatives --install ${bindir}/traceroute traceroute traceroute.${PN} 100
+ update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 100
+ update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove tftp tftp.${PN}
+ update-alternatives --remove telnet telnet.${PN}
+ update-alternatives --remove logger logger.${PN}
+ update-alternatives --remove traceroute traceroute.${PN}
+ update-alternatives --remove ifconfig ifconfig.${PN}
+}