aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/blueman/blueman_git.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-10-12 08:26:21 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-12 13:08:17 -0700
commit0dfc9ab6f069924a17c523e61c7e37b380248fc0 (patch)
tree0cf2477947d2dd6dcb30b973f0d32fcdd1363414 /meta-networking/recipes-connectivity/blueman/blueman_git.bb
parent47a9cc6c5397fbc482e2eb895d1139b1b67aa555 (diff)
downloadmeta-openembedded-contrib-0dfc9ab6f069924a17c523e61c7e37b380248fc0.tar.gz
blueman: really belongs in meta-networking
it has a build dependancy on python-cython and python-pyparsing with are in meta-python Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/blueman/blueman_git.bb')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_git.bb b/meta-networking/recipes-connectivity/blueman/blueman_git.bb
new file mode 100644
index 0000000000..947db78360
--- /dev/null
+++ b/meta-networking/recipes-connectivity/blueman/blueman_git.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
+
+inherit autotools systemd gsettings python3native gtk-icon-cache
+
+SRC_URI = " \
+ git://github.com/blueman-project/blueman.git \
+ file://0001-Search-for-cython3.patch \
+"
+SRCREV = "c4a03417e81e21543d4568e8e7f7de307582eb50"
+PV = "2.0.5+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = " \
+ --disable-runtime-deps-check \
+ --disable-schemas-compile \
+"
+
+SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+RRECOMENDS_${PN} += "adwaita-icon-theme"
+RDEPENDS_${PN} += " \
+ python3-dbus \
+ packagegroup-tools-bluetooth \
+"
+
+PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto,,thunar"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${datadir}/Thunar \
+ ${systemd_user_unitdir} \
+ ${exec_prefix}${systemd_system_unitdir} \
+ ${PYTHON_SITEPACKAGES_DIR} \
+"
+
+FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"