aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorMadhavan Krishnan <madhavan.krishnan@linaro.org>2020-08-28 15:50:45 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-08 11:56:46 -0700
commitf4272f2abf95f79d6868034aba653c682fca293f (patch)
tree29490aa7d51ff095bb32e0f4693847b062548d7a /meta-multimedia
parentc75ffccd840449ba7de745d6f8eae811adb29ff4 (diff)
downloadmeta-openembedded-contrib-f4272f2abf95f79d6868034aba653c682fca293f.tar.gz
libcamera: Bumped to latest revision and added pkgconfig to enable gstreamer
Bumped to latest source revision of libcamera, and added packageconfig to enable the gstreamer during build, and to generate and install the gstreamer library. Signed-off-by: Madhavan Krishnan <madhavan.krishnan@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
index c66c93ec5a..5505626d3e 100644
--- a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
@@ -12,15 +12,20 @@ SRC_URI = " \
git://linuxtv.org/libcamera.git;protocol=git \
"
-SRCREV = "5f2f9406cebc668f0d69007d1ea59ef3c56ef28c"
+SRCREV = "1e8c91b65695449c5246d17ba7dc439c8058b781"
-PV = "202006+git${SRCPV}"
+PV = "202008+git${SRCPV}"
S = "${WORKDIR}/git"
DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
+PACKAGES =+ "${PN}-gst"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
+
RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
inherit meson pkgconfig python3native
@@ -44,4 +49,4 @@ do_recalculate_ipa_signatures_package() {
FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
FILES_${PN} += " ${libdir}/libcamera.so"
-
+FILES_${PN}-gst = "${libdir}/gstreamer-1.0/libgstlibcamera.so"