aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorPeter Griffin <peter.griffin@linaro.org>2022-02-01 20:52:29 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-03 08:44:32 -0800
commitea6d967dbe396072b5ba58331bb07252c3c449c4 (patch)
tree9f0eb8f72d9ebd8169f091d13e62bd61ca1c8209 /meta-multimedia
parent014835f162456611d868ddc09aa9ece70111c89c (diff)
downloadmeta-openembedded-contrib-ea6d967dbe396072b5ba58331bb07252c3c449c4.tar.gz
libcamera: update meson options to build pipeline handlers & cam utility
Enable uvcvideo, simple, and vimc pipeline handlers in libcamera. Without any pipeline handlers libcamera can't capture any frames. Also enable cam utility with is a cli utility that can use the library to capture some frames. Signed-off-by: Peter Griffin <peter.griffin@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
index 82028ecb37..a8d54f08f6 100644
--- a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
@@ -18,7 +18,7 @@ PV = "202105+git${SRCPV}"
S = "${WORKDIR}/git"
-DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls boost chrpath-native"
+DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls boost chrpath-native libevent"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
PACKAGES =+ "${PN}-gst"
@@ -26,6 +26,16 @@ PACKAGES =+ "${PN}-gst"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
+EXTRA_OEMESON = " \
+ -Dpipelines=uvcvideo,simple,vimc \
+ -Dipas=vimc \
+ -Dv4l2=true \
+ -Dcam=enabled \
+ -Dlc-compliance=disabled \
+ -Dtest=false \
+ -Ddocumentation=disabled \
+"
+
RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
inherit meson pkgconfig python3native
@@ -59,4 +69,6 @@ FILES:${PN} += " ${libdir}/libcamera.so.0.0.0"
FILES:${PN}-dev += " ${libdir}/libcamera-base.so"
FILES:${PN}-dev += " ${libdir}/libcamera-base.so.0"
FILES:${PN} += " ${libdir}/libcamera-base.so.0.0.0"
+FILES:${PN} += " ${libdir}/v4l2-compat.so"
FILES:${PN}-gst = "${libdir}/gstreamer-1.0/libgstlibcamera.so"
+FILES:${PN} += " ${bindir}/cam"