aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-12-01 12:16:56 -0800
committerKhem Raj <raj.khem@gmail.com>2021-12-01 12:39:28 -0800
commit260968790546acce067ab1265f53ceb40791dfa1 (patch)
treea8b963361ddf849406f03e8e12bd5681dc9a8fae /meta-multimedia
parent6950f120606acf927dcc21395f173210eb532d1b (diff)
downloadmeta-openembedded-contrib-260968790546acce067ab1265f53ceb40791dfa1.tar.gz
libcamera: Fix build break on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera.bb1
-rw-r--r--meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch41
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
index be88fded37..97b920cead 100644
--- a/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera.bb
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "\
SRC_URI = " \
git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
+ file://0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch \
"
SRCREV = "f47c9c36ed161c9afefe7d4910840fd41f38ae3d"
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch
new file mode 100644
index 0000000000..3c01c5a23c
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0001-backtrace-Include-cxxabi.h-without-HAVE_DW.patch
@@ -0,0 +1,41 @@
+From 8aa0d83749609ed571b984d2dc64c7f757950c7c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 1 Dec 2021 12:10:11 -0800
+Subject: [PATCH v2] backtrace: Include cxxabi.h without HAVE_DW
+
+Since its used in code without HAVE_DW, it fails to compile on such
+systems e.g. linux/musl
+
+Fixes
+src/libcamera/base/backtrace.cpp:235:16: error: use of undeclared identifier 'abi'
+ char *name = abi::__cxa_demangle(symbol, nullptr, nullptr, nullptr);
+ ^
+1 error generated.
+
+Upstream-Status: Submitted [https://lists.libcamera.org/pipermail/libcamera-devel/2021-December/027989.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/libcamera/base/backtrace.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/libcamera/base/backtrace.cpp b/src/libcamera/base/backtrace.cpp
+index d93e5518..42c60f7c 100644
+--- a/src/libcamera/base/backtrace.cpp
++++ b/src/libcamera/base/backtrace.cpp
+@@ -13,11 +13,12 @@
+ #endif
+
+ #ifdef HAVE_DW
+-#include <cxxabi.h>
+ #include <elfutils/libdwfl.h>
+ #include <unistd.h>
+ #endif
+
++#include <cxxabi.h>
++
+ #if HAVE_UNWIND
+ /*
+ * Disable support for remote unwinding to enable a more optimized
+--
+2.34.1
+