aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-10-11 19:47:24 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-14 11:48:57 +0200
commit95d78c37107fe6f11238a020fb5ce11ce76e9635 (patch)
tree5403b75f9a614e49ee56438860ee3a83fdc0fb6a /meta-multimedia
parentf48e71ec3e3401231eb66fc810e7c18f0e659b47 (diff)
downloadmeta-openembedded-contrib-95d78c37107fe6f11238a020fb5ce11ce76e9635.tar.gz
vlc: make opencv explicitly configurable
World builds are failing due to change in opencv in API. Since vlc is only using opencv as an example and a filter, disable by default. Revisit when upstream adapts to new opencv API. Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc3
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch29
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb1
3 files changed, 32 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 88605dfaa7..72a93f57f7 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -10,7 +10,7 @@ DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \
tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \
libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \
libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \
- libmtp opencv libopus orc libusb1 schroedinger taglib \
+ libmtp libopus orc libusb1 schroedinger taglib \
tiff xcb-util-keysyms samba"
SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
@@ -50,6 +50,7 @@ PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555"
PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml"
PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc,libpostproc"
+PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
do_configure_prepend() {
cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
new file mode 100644
index 0000000000..950c09b8ae
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
@@ -0,0 +1,29 @@
+Recent opencv API changes break upstream filter and example.
+Make opencv explicitly configurable.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Tim Orling <TicoTimo@gmail.com>
+
+Index: vlc-2.1.4/configure.ac
+===================================================================
+--- vlc-2.1.4.orig/configure.ac
++++ vlc-2.1.4/configure.ac
+@@ -1693,7 +1693,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
+ dnl
+ dnl OpenCV wrapper and example filters
+ dnl
+-PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
++AC_ARG_ENABLE(opencv,
++ [AS_HELP_STRING([--disable-opencv],
++ [disable OpenCV computer vision filter and example (default auto)])])
++if test "${enable_opencv}" != "no"
++then
++ PKG_ENABLE_MODULES_VLC([OPENCV],
++ [opencv_example opencv_wrapper],
++ [opencv > 2.0],
++ (OpenCV (computer vision) filter), [auto])
++fi
+
+
+ dnl
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb
index b4047d3be4..418f77cfcf 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.4.bb
@@ -8,6 +8,7 @@ SRC_URI += "file://0001-enable-subdir-objects.patch \
file://0003-use-am-path-libgcrypt.patch \
file://0004-modules-gui-qt4-out-of-tree-build.patch \
file://0005-libpostproc-header-check.patch \
+ file://0006-make-opencv-configurable.patch \
"
SRC_URI[md5sum] = "7ed67d22f7425011078772bfc62ac222"