aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-10-22 22:09:39 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-26 21:37:37 +0100
commit9dbf3c5b024bbdef1aa3ecbe41f646703ed372dc (patch)
tree798ffb684976d9470b6d20e4b1d0078408bd35c1 /meta-multimedia
parentba8b86175ee3d11fec13d521f77da137c91be150 (diff)
downloadmeta-openembedded-contrib-9dbf3c5b024bbdef1aa3ecbe41f646703ed372dc.tar.gz
vlc: fix freerdp module build
Since we are building "freerdp" again, build can now fail due to reliance on removed APIs. For instance : http://errors.yoctoproject.org/Errors/Details/20603/ Fix this by conditionally building the module, and if we build it, patching the code until the fix gets merged upstream. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc1
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0009-fix-rdp-module.patch19
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb3
3 files changed, 22 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 41b5df92d1..ee90ac8048 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -57,6 +57,7 @@ PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
PACKAGECONFIG[gstreamer] = "--enable-gst-decode,--disable-gst-decode,gstreamer1.0 gstreamer1.0-plugins-base"
PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx, libvpx"
PACKAGECONFIG[qt4] = "--enable-qt,--disable-qt, qt4-x11-free"
+PACKAGECONFIG[freerdp] = "--enable-freerdp,--disable-freerdp, freerdp"
do_configure_prepend() {
cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0009-fix-rdp-module.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0009-fix-rdp-module.patch
new file mode 100644
index 0000000000..8e554a9805
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0009-fix-rdp-module.patch
@@ -0,0 +1,19 @@
+--- a/modules/access/rdp.c 2015-10-22 19:42:24.447445250 +0000
++++ b/modules/access/rdp.c 2015-10-22 19:42:46.570445248 +0000
+@@ -428,8 +428,6 @@
+ if ( p_sys->f_fps <= 0 ) p_sys->f_fps = 1.0;
+ p_sys->i_frame_interval = 1000000 / p_sys->f_fps;
+
+- freerdp_channels_global_init();
+-
+ p_sys->p_instance = freerdp_new();
+ if ( !p_sys->p_instance )
+ {
+@@ -504,7 +502,6 @@
+
+ freerdp_disconnect( p_sys->p_instance );
+ freerdp_free( p_sys->p_instance );
+- freerdp_channels_global_uninit();
+
+ if ( p_sys->p_block )
+ block_Release( p_sys->p_block );
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb
index ba8ca4b5a3..fa9d11a11a 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_2.2.1.bb
@@ -9,8 +9,9 @@ SRC_URI += "file://0001-enable-subdir-objects.patch \
file://0004-modules-gui-qt4-out-of-tree-build.patch \
file://0005-libpostproc-header-check.patch \
file://0006-make-opencv-configurable.patch \
- file://0007-use-vorbisidec.patch \
+ file://0007-use-vorbisidec.patch \
file://0008-fix-luaL-checkint.patch \
+ file://0009-fix-rdp-module.patch \
"
SRC_URI[md5sum] = "42273945758b521c408fabc7fd6d9946"