aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-support/srt/srt_1.4.2.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2020-11-14 15:04:43 +0000
committerKhem Raj <raj.khem@gmail.com>2020-11-15 12:25:18 -0800
commit23343cb8e9497981e4ef14d5eeae5df9bf891624 (patch)
tree0554995e56555087f0cc125f6d526907b89b79ed /meta-multimedia/recipes-support/srt/srt_1.4.2.bb
parent291e48127e36170df7cec36633d3d0d6547c13e1 (diff)
downloadmeta-openembedded-contrib-23343cb8e9497981e4ef14d5eeae5df9bf891624.tar.gz
srt: add receipe
Secure Reliable Transport (SRT) Protocol Secure Reliable Transport (SRT) is an open source transport technology that optimizes streaming performance across unpredictable networks, such as the Internet. SRT is applied to contribution and distribution endpoints as part of a video stream workflow to deliver the best quality and lowest latency video at all times. As audio/video packets are streamed from a source to a destination device, SRT detects and adapts to the real-time network conditions between the two endpoints. SRT helps compensate for jitter and bandwidth fluctuations due to congestion over noisy networks, such as the Internet. Its error recovery mechanism minimizes the packet loss typical of Internet connections. And SRT supports AES encryption for end-to-end security, keeping your streams safe from prying eyes. * 0001-don-t-install-srt-ffplay.patch Upstream-Status: Pending Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-support/srt/srt_1.4.2.bb')
-rw-r--r--meta-multimedia/recipes-support/srt/srt_1.4.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-support/srt/srt_1.4.2.bb b/meta-multimedia/recipes-support/srt/srt_1.4.2.bb
new file mode 100644
index 0000000000..567ea68edf
--- /dev/null
+++ b/meta-multimedia/recipes-support/srt/srt_1.4.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Secure Reliable Transport (SRT) Protocol"
+DESCRIPTION = "Secure Reliable Transport (SRT) is an open source transport technology \
+that optimizes streaming performance across unpredictable networks, such as the Internet."
+SECTION = "libs"
+HOMEPAGE = "https://github.com/Haivision/srt"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRCREV = "50b7af06f3a0a456c172b4cb3aceafa8a5cc0036"
+SRC_URI = "git://github.com/Haivision/srt;protocol=https \
+ file://0001-don-t-install-srt-ffplay.patch \
+ "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DENABLE_UNITTESTS=OFF"
+
+PACKAGECONFIG ??= "crypt"
+PACKAGECONFIG[debug] = "-DENABLE_DEBUG=1,,"
+PACKAGECONFIG[crypt] = "-DENABLE_ENCRYPTION=ON,-DENABLE_ENCRYPTION=OFF,openssl"
+PACKAGECONFIG[utils] = "-DENABLE_APPS=ON,-DENABLE_APPS=OFF,"
+
+PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'utils', '${PN}-utils', '', d)}"
+FILES_${PN}-utils += "${bindir}"
+RDEPENDS_${PN}-utils += "${PN}"