aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-06-08 01:30:01 +0200
committerKhem Raj <raj.khem@gmail.com>2020-06-08 22:00:37 -0700
commitaadbc77f8e132301403c1187e8d0488d526f8817 (patch)
treea7a83ef02705517dd2fb21763755aa5d00de9f7a /meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
parent91b30560e4a4e5a40744d01dfa1339ad8ba96a7e (diff)
downloadmeta-openembedded-contrib-aadbc77f8e132301403c1187e8d0488d526f8817.tar.gz
vlc: Fix build with qt5 in PACKAGECONFIG and Qt >= 5.15 / renumber patches
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
new file mode 100644
index 0000000000..950c09b8ae
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
@@ -0,0 +1,29 @@
+Recent opencv API changes break upstream filter and example.
+Make opencv explicitly configurable.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Tim Orling <TicoTimo@gmail.com>
+
+Index: vlc-2.1.4/configure.ac
+===================================================================
+--- vlc-2.1.4.orig/configure.ac
++++ vlc-2.1.4/configure.ac
+@@ -1693,7 +1693,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
+ dnl
+ dnl OpenCV wrapper and example filters
+ dnl
+-PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
++AC_ARG_ENABLE(opencv,
++ [AS_HELP_STRING([--disable-opencv],
++ [disable OpenCV computer vision filter and example (default auto)])])
++if test "${enable_opencv}" != "no"
++then
++ PKG_ENABLE_MODULES_VLC([OPENCV],
++ [opencv_example opencv_wrapper],
++ [opencv > 2.0],
++ (OpenCV (computer vision) filter), [auto])
++fi
+
+
+ dnl