aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2017-12-01 12:08:10 +0100
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:56 -0800
commitda778f933ccf34d01dfe8ca273c2191acfb36ef3 (patch)
tree80ee785896568c2fd6d8b64012090a9ad21446aa /meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
parentc0b74f42e00c84ba8419bc28de564cfa5c8d7987 (diff)
downloadmeta-openembedded-contrib-da778f933ccf34d01dfe8ca273c2191acfb36ef3.tar.gz
fluidsynth: performance improvements
* Use floats instead of double for sound calculations. This improves performance notable and was default for version 1.1.6 using autotools. * Fix buffer overrun when using floats * Make use of ARM NEON for multithreading enabled Performance and sound correctnes was tested with qtractor and a reworked version of fluidsynth-dssi [1-2]. Tests were performed for single- and multithreading enabled. [1] https://github.com/schnitzeltony/fluidsynth-dssi/commit/bad09c6f5c5508c5f5330aa5188510f975e50c50 [2] https://github.com/schnitzeltony/meta-qt5-extra/blob/master/recipes-misc/recipes-multimedia/fluidsynth/fluidsynth-dssi_1.0.0.bb Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
index ef4c6065f6..406bbf7688 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
@@ -6,13 +6,17 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
DEPENDS = "alsa-lib ncurses glib-2.0"
-SRC_URI = "git://github.com/FluidSynth/fluidsynth.git;branch=1.1.x"
+SRC_URI = " \
+ git://github.com/FluidSynth/fluidsynth.git;branch=1.1.x \
+ file://0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch \
+ file://0002-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
+"
SRCREV = "12e7afe3a806a6b397f28e0ca4bc6bab9ebe7047"
S = "${WORKDIR}/git"
inherit cmake pkgconfig lib_package
-EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
PACKAGECONFIG[sndfile] = "-Denable-libsndfile-support=ON,-Denable-libsndfile-support=OFF,libsndfile1"