aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-12-21 14:00:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-18 10:49:43 +0100
commitd3bcb21db84a04bfaaa239f287513ad51bd9f613 (patch)
tree1e8196ed2740b013c84bc97ecf7c0a94eb964e35 /meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
parent38a5cf3fa06972992f473027658d5b0cffff3a33 (diff)
downloadmeta-openembedded-contrib-d3bcb21db84a04bfaaa239f287513ad51bd9f613.tar.gz
tvheadend: add git version
"Tvheadend is a TV streaming server for Linux supporting DVB-S, DVB-S2, DVB-C, DVB-T, ATSC, IPTV, and Analog video (V4L) as input sources." No startup scripts or config files are currently provided. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb')
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
new file mode 100644
index 0000000000..212bca16e3
--- /dev/null
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Tvheadend TV streaming server"
+HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend"
+
+DEPENDS = "avahi zlib openssl python-native"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9eef91148a9b14ec7f9df333daebc746"
+
+SRC_URI = "git://github.com/tvheadend/tvheadend.git \
+ file://0001-Move-tvheadend-specific-LD-CFLAGS-into-a-helper-vari.patch \
+ "
+SRCREV = "a420c83a0e0d2c31c2c15d0fec6fedc3f5a36dfe"
+PV = "3.3"
+
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ./configure --prefix=${prefix} \
+ --libdir=${libdir} \
+ --bindir=${bindir} \
+ --datadir=${datadir} \
+ --arch=${TARGET_ARCH} \
+ --disable-bundle
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${datadir}/${BPN}"