aboutsummaryrefslogtreecommitdiffstats
path: root/meta-maker/recipes-printing/slic3r/slic3r_git.bb
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-11 19:51:27 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:47:44 -0700
commit7d07455d5a5b12428a5778d1316bd62b0f9940c9 (patch)
tree7292eb33f3a7dfe5d0442eebf567642263c2cff4 /meta-maker/recipes-printing/slic3r/slic3r_git.bb
parent63dc55bbf00e685890850d4d9e94ecd52524846d (diff)
downloadmeta-openembedded-contrib-7d07455d5a5b12428a5778d1316bd62b0f9940c9.tar.gz
slic3r: update to git master
* v1.1.6 was broken for perl 5.20.0 - fixed with commit 67bf99633e48f9c8a5863b88c2a03fddc1cc247f * Create a separate recipe for libslic3r-xs-perl * Fixes for install locations for Slic3r/XS.pm, auto/Slic3r/XS/XS.* NOTE: perl Build.PL is not generating a Build script... TODO: add gui requires and recommends Hardcode install of slic3r.pl to ${bindir}? Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-maker/recipes-printing/slic3r/slic3r_git.bb')
-rw-r--r--meta-maker/recipes-printing/slic3r/slic3r_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-maker/recipes-printing/slic3r/slic3r_git.bb b/meta-maker/recipes-printing/slic3r/slic3r_git.bb
new file mode 100644
index 0000000000..6c45a53af8
--- /dev/null
+++ b/meta-maker/recipes-printing/slic3r/slic3r_git.bb
@@ -0,0 +1,67 @@
+SUMMARY = "Slic3r - G-code generator for 3D printers"
+DESCRIPTION = "Slic3r takes 3D models (STL, OBJ, AMF) and converts them into \
+G-code instructions for 3D printers. It's compatible with any modern printer \
+based on the RepRap toolchain, including all those based on the Marlin, \
+Sprinter and Repetier firmware. It also works with Mach3 and LinuxCNC \
+controllers. \
+"
+HOMEPAGE = "http://slic3r.org/"
+SECTION = "devel"
+
+LICENSE = "AGPL-3.0 | CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README.md;beginline=77;endline=84;md5=4e907cb01787f6711506359a57c22961"
+
+export SLIC3R_NO_AUTO = "1"
+
+DEPENDS = " libcapture-tiny-perl-native \
+ libconstant-defer-perl-native \
+ libencode-locale-perl-native \
+ libextutils-cppguess-perl-native \
+ libextutils-parsexs-perl-native \
+ libextutils-typemaps-default-perl-native \
+ libio-stringy-perl-native \
+ libmath-libm-perl-native \
+ libmath-planepath-perl-native \
+ libmodule-build-withxspp-perl-native \
+ libmoo-perl-native \
+ libslic3r-xs-perl-native \
+"
+PACKAGES =+ "gui"
+DEPENDS_${PN}-gui = " libwx-perl-native"
+
+RECOMMENDS_${PN}-gui = " libgrowl-gntp-perl-native \
+ libwx-glcanvas-perl-native \
+ libopengl-perl-native \
+"
+
+
+SRC_URI = "git://github.com/alexrj/Slic3r.git"
+SRCREV = "f82a8475a1ccd7ca9ebddd31d6b60953a26b5f39"
+
+S = "${WORKDIR}/git"
+
+inherit cpan_build
+
+RDEPENDS_${PN} = " libencode-locale-perl \
+ libextutils-makemaker-perl \
+ libextutils-parsexs-perl \
+ perl-module-file-basename \
+ perl-module-file-spec \
+ perl-module-getopt-long \
+ libmath-planepath-perl \
+ libmodule-build-withxspp-perl \
+ libmoo-perl \
+ perl-module-scalar-util \
+ libtest-harness-perl \
+ libio-scalar-perl \
+ libslic3r-xs-perl \
+ perl-module-time-hires \
+"
+
+RECOMMENDS += " libclass-xsaccessor-perl-native \
+ libgrowl-gntp-perl-native \
+ libxml-sax-expatxs-perl-native \
+ libwx-perl-native \
+"
+
+BBCLASSEXTEND = "native"