aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2021-06-13 00:53:59 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-12 23:02:49 -0700
commit93e139c998857048182ed4169f04cfe350eab013 (patch)
tree2b2b1b360e92af2ec9f303fe1c1feec0bc2a049d /meta-initramfs
parentcdce92b4e9e82327fe2b3118384c424d7f08cc0c (diff)
downloadmeta-openembedded-contrib-93e139c998857048182ed4169f04cfe350eab013.tar.gz
initramfs-debug-image: support cases where machines override IMAGE_FSTYPES
As done for initramfs-kexecboot-image we need to use python to get the desired value for IMAGE_FSTYPES. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-core/images/initramfs-debug-image.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
index c3dcd2b821..601056b7e5 100644
--- a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
+++ b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
@@ -11,7 +11,12 @@ IMAGE_FEATURES = ""
export IMAGE_BASENAME = "initramfs-debug-image"
IMAGE_LINGUAS = ""
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+# Some BSPs use IMAGE_FSTYPES_<machine override> which would override
+# an assignment to IMAGE_FSTYPES so we need anon python
+python () {
+ d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
+}
+
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"