aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-12 22:31:18 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commit95bf58c16e40d182d55b29c2858364e6a31dd160 (patch)
tree8defc4a9d805ef01e2ca291e4e6d0e4bc7a05b1d /meta-initramfs
parent000c6a181e2fb989270925a5b918172fb01ef47a (diff)
downloadmeta-openembedded-contrib-95bf58c16e40d182d55b29c2858364e6a31dd160.tar.gz
kexecboot: Use -fcommon to compile
gcc10 defaults to -fno-common and kexecboot does not compile with -fno-common, so use -fcommon explicitly Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index ed3dece3f6..2f46fa9523 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -13,6 +13,8 @@ inherit autotools
EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
+CFLAGS += "-fcommon"
+
do_install () {
install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
install -d ${D}/proc