aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-11 14:51:13 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-15 08:20:06 -0700
commit85b0d91d397fd46922c9266db13e725f36968837 (patch)
tree69070c7e06c65ba034d81bc79daff89524e7eb8e /meta-initramfs
parentb19f8c7d6e98b911620ea6fdb606339f49aca18a (diff)
downloadmeta-openembedded-contrib-85b0d91d397fd46922c9266db13e725f36968837.tar.gz
kexecboot: Fix build with glibc 2.28+
Update to latest srcrev at the same time. Fix out of tree builds Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch27
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch30
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb10
3 files changed, 63 insertions, 4 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
new file mode 100644
index 0000000000..0565133d95
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
@@ -0,0 +1,27 @@
+From d302547305727797e0172ba89e7519252c400021 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 11 Aug 2018 14:37:22 -0700
+Subject: [PATCH 1/2] Add top_srcdir to compiler include paths
+
+Helps in compiling with out of tree build dir
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index d04a3a8..6449c5a 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,7 @@
+ bin_PROGRAMS=kexecboot
+
++kexecboot_CFLAGS = -I$(top_srcdir)
++
+ kexecboot_SOURCES = \
+ util.c \
+ cfgparser.c \
+--
+2.18.0
+
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
new file mode 100644
index 0000000000..f12ae99e72
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
@@ -0,0 +1,30 @@
+From c587012cbe448c9295f50497812ca3530cabbb51 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 11 Aug 2018 14:39:01 -0700
+Subject: [PATCH 2/2] include sys/sysmacros.h
+
+glibc 2.28+ does not include this header implicitly via other system
+headers anymore
+
+src/devicescan.c:373: undefined reference to `makedev'
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/devicescan.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/devicescan.c b/src/devicescan.c
+index 4f2f497..0b2b253 100644
+--- a/src/devicescan.c
++++ b/src/devicescan.c
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+--
+2.18.0
+
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 9f5dad7c64..8799a3e4cc 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -38,15 +38,17 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
PV = "0.6+git${SRCPV}"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/kexecboot/kexecboot.git"
-SRCREV = "4c4f127e79ac5b8d6b6e2fbb938ccbf12b04c531"
+SRC_URI = "git://github.com/kexecboot/kexecboot.git \
+ file://0001-Add-top_srcdir-to-compiler-include-paths.patch \
+ file://0002-include-sys-sysmacros.h.patch \
+ "
+SRCREV = "d5ffd81bf6a1a2087cdc6c606cae98099229131c"
inherit autotools
EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}
+ install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
install -d ${D}/proc
install -d ${D}/mnt
install -d ${D}/dev