aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-05-09 14:28:40 -0400
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:20:48 -0700
commit9b08b7af9e6fd574c291bab4b0e570152a5f1861 (patch)
tree3c40a3106b4de2baf60d86a9c38186db957e26b2 /meta-initramfs/recipes-devtools/grubby/grubby_git.bb
parente3812fa4adae60a93193dabd0ecdcafbe8315f33 (diff)
downloadmeta-openembedded-contrib-9b08b7af9e6fd574c291bab4b0e570152a5f1861.tar.gz
grubby: update to latest
This project doesn't seem to produce regular releases as they once did, the last such release (8.40-1) was in 2015 (over 3 years ago at this point). Therefore switch to building the latest git commit. Also, refresh the patches as required (used devtool --force-patch-refresh). Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools/grubby/grubby_git.bb')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby_git.bb b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
new file mode 100644
index 0000000000..8430b7e102
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A command line tool for updating and displaying info about boot loaders"
+DESCRIPTION = "grubby is a command line tool for updating and displaying information \
+about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
+zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
+new kernels and need to find information about the current boot environment. \
+"
+HOMEPAGE = "https://github.com/rhboot/grubby"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
+
+DEPENDS = "popt util-linux"
+DEPENDS_append_libc-musl = " libexecinfo"
+
+S = "${WORKDIR}/git"
+SRCREV = "a1d2ae93408c3408e672d7eba4550fdf27fb0201"
+SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https; \
+ file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
+ file://run-ptest \
+ file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
+ file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
+ "
+
+RDEPENDS_${PN} += "dracut"
+
+inherit autotools-brokensep ptest
+
+EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'"
+
+LIBS_libc-musl = "-lexecinfo"
+LIBS ?= ""
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
+ sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
+}
+
+RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'