aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRob Woolley <rob.woolley@windriver.com>2017-09-13 22:44:40 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-18 10:18:11 +0200
commit6fa7a7d85efa490add3b13e2937dab625dac721a (patch)
tree9afa69d197f7a7b92adbc9009575ebdc2a3a49f8 /meta-gnome
parent476e3c24fd7def2b6056eda7a6f13e59d643b782 (diff)
downloadmeta-openembedded-contrib-6fa7a7d85efa490add3b13e2937dab625dac721a.tar.gz
gnome-keyring: Resolve conflict with gcr 3 and gold linking error
The gnome-keyring is used to configure save certain wifi attributes when using xfce or a gnome based UI. Removing org.gnome.crypto.pgp.* makes gnome-keyring compatible with gcr 3. The gnome-keyring needs libgmodule to be explicitly added in order to satisfy the gold linker. This is necessary because pkg-config doesn't list libgmodule as one of the libraries for gtk+-2.0. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Rob Woolley <rob.woolley@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
index 4ac75cbef9..3b4cbf57f9 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -20,6 +20,8 @@ SRC_URI += "file://egg-asn1x.patch"
DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native"
RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
+LDFLAGS += "-lgmodule-2.0"
+
EXTRA_OECONF = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
@@ -42,4 +44,11 @@ FILES_${PN}-dbg += "${libdir}/${BPN}/standalone/.debug/ \
${libdir}/${BPN}/devel/.debug/ \
${base_libdir}/security/.debug/"
-PNBLACKLIST[gnome-keyring] ?= "This version conflicts with gcr from oe-core - the recipe will be removed on 2017-09-01 unless the issue is fixed"
+# Make compatible with gcr version 3 or newer by removing
+# org.gnome.crypto.pgp.*, which is the provider for this optional
+# functionality.
+
+do_install_append() {
+ rm ${D}${datadir}/GConf/gsettings/org.gnome.crypto.pgp.convert
+ rm ${D}${datadir}/glib-2.0/schemas/org.gnome.crypto.pgp.gschema.xml
+}