aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-01-21 14:32:55 +0100
committerKhem Raj <raj.khem@gmail.com>2022-01-24 09:11:01 -0800
commit268f962dd57aadd1e9cc91f30486b9f2f4f0224f (patch)
treed30b883de05186aa565d2d7130be64e5e4220d33 /meta-gnome
parentccd5c225fd4fb422fc6e0e34f320f6f51a5e5ca4 (diff)
downloadmeta-openembedded-contrib-268f962dd57aadd1e9cc91f30486b9f2f4f0224f.tar.gz
folks: initial add recipe
Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-connectivity/folks/folks_0.15.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-gnome/recipes-connectivity/folks/folks_0.15.4.bb b/meta-gnome/recipes-connectivity/folks/folks_0.15.4.bb
new file mode 100644
index 0000000000..3e57fbb0d1
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/folks/folks_0.15.4.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Folks is a contact aggregation library."
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = " \
+ dbus-glib \
+ glib-2.0 \
+ libgee \
+ libxml2 \
+ python3-dbusmock-native \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+GIR_MESON_OPTION = ""
+
+PACKAGECONFIG[eds] = "-Deds_backend=true,-Deds_backend=false,evolution-data-server"
+PACKAGECONFIG[bluez] = "-Dbluez_backend=true,-Dbluez_backend=false"
+PACKAGECONFIG[ofono] = "-Dofono_backend=true,-Dofono_backend=false"
+PACKAGECONFIG[telepathy] = "-Dtelepathy_backend=true,-Dtelepathy_backend=false,telepathy-glib"
+
+PACKAGECONFIG ??= ""
+
+inherit pkgconfig gnomebase gettext gobject-introspection vala features_check
+
+SRC_URI[archive.sha256sum] = "e71099afc9e88fad4e757ae134bc3fd63e12b901ad62b0ed5536afb79124af5f"
+