aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-03-03 15:09:00 +0100
committerKhem Raj <raj.khem@gmail.com>2022-03-03 23:07:50 -0800
commitd69c574e1eb6a59238db6e8944e2cfb73c1ed6a3 (patch)
treea11d73c59a335ab25fa759571885aba36687efb2 /meta-gnome
parent960409f5a3f2e6985f15cdd51715ddca9cfafae5 (diff)
downloadmeta-openembedded-contrib-d69c574e1eb6a59238db6e8944e2cfb73c1ed6a3.tar.gz
gjs: update; customize dependencies
Disable gtk_tests to be able to drop gtk4 dependency Update mozjs dependency to mozjs-91 since polkit also builds with it. These changes should reduce the compilation of additional packages and thus save space and time during build. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-Support-cross-builds-a-bit-better.patch17
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch9
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.71.1.bb (renamed from meta-gnome/recipes-gnome/gjs/gjs_1.70.1.bb)5
3 files changed, 13 insertions, 18 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-Support-cross-builds-a-bit-better.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-Support-cross-builds-a-bit-better.patch
index 55af681af0..0c45e60957 100644
--- a/meta-gnome/recipes-gnome/gjs/gjs/0001-Support-cross-builds-a-bit-better.patch
+++ b/meta-gnome/recipes-gnome/gjs/gjs/0001-Support-cross-builds-a-bit-better.patch
@@ -1,4 +1,4 @@
-From 550e98013b0e003c1a6771d8e811375913adf16b Mon Sep 17 00:00:00 2001
+From fa47185d9c8150a0dcb0ea12b92fcf139edbef35 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Wed, 27 Oct 2021 20:18:47 +0200
Subject: [PATCH] Support cross builds a bit better
@@ -17,10 +17,10 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index dfcc2c3..192b1b5 100644
+index 136e812..f5b91e0 100644
--- a/meson.build
+++ b/meson.build
-@@ -234,6 +234,7 @@ release builds of SpiderMonkey. Try configuring SpiderMonkey with
+@@ -252,6 +252,7 @@ release builds of SpiderMonkey. Try configuring SpiderMonkey with
--disable-debug.''')
endif
@@ -28,15 +28,15 @@ index dfcc2c3..192b1b5 100644
# Check if a minimal SpiderMonkey program compiles, links, and runs. If not,
# it's most likely the case that SpiderMonkey was configured incorrectly, for
# example by building mozglue as a shared library.
-@@ -254,6 +255,7 @@ could not be compiled, linked, or run. Most likely you should build it with a
- different configuration. Check the recommended configuration:
- https://github.com/spidermonkey-embedders/spidermonkey-embedding-examples/blob/esr78/docs/Building%20SpiderMonkey.md''')
+@@ -282,6 +283,7 @@ elif minimal_program.returncode() != 0
+ failed to execute. Most likely you should build it with a different
+ configuration.''' + recommended_configuration)
endif
+endif # not meson.is_cross_build()
have_printf_alternative_int = cc.compiles('''
#include <stdio.h>
-@@ -662,7 +664,7 @@ endif
+@@ -682,7 +684,7 @@ subdir('installed-tests')
# Note: The test program in test/ needs to be ported
# to Windows before we can build it on Windows.
@@ -45,6 +45,3 @@ index dfcc2c3..192b1b5 100644
subdir('test')
endif
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch b/meta-gnome/recipes-gnome/gjs/gjs/0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch
index 8777d14f53..6e7b5504e8 100644
--- a/meta-gnome/recipes-gnome/gjs/gjs/0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch
+++ b/meta-gnome/recipes-gnome/gjs/gjs/0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch
@@ -1,4 +1,4 @@
-From 6a29818204e647d5fad68ed7ca8cac53d301cae6 Mon Sep 17 00:00:00 2001
+From 2b8aa1ea4a4d1836164c934b1ab2556a32cb5af7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Wed, 27 Oct 2021 20:04:02 +0200
Subject: [PATCH] meson.build: Do not add dir installed-tests when
@@ -15,10 +15,10 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 6878e2e..edbbf79 100644
+index f5b91e0..3110530 100644
--- a/meson.build
+++ b/meson.build
-@@ -635,7 +635,9 @@ if not get_option('skip_gtk_tests')
+@@ -680,7 +680,9 @@ if not get_option('skip_gtk_tests')
have_gtk4 = dependency('gtk4', required: false).found()
endif
@@ -29,6 +29,3 @@ index 6878e2e..edbbf79 100644
# Note: The test program in test/ needs to be ported
# to Windows before we can build it on Windows.
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.70.1.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.71.1.bb
index 90ea140448..9c3d441d1b 100644
--- a/meta-gnome/recipes-gnome/gjs/gjs_1.70.1.bb
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.71.1.bb
@@ -4,11 +4,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8dcea832f6acf45d856abfeb2d51ec48"
GNOMEBASEBUILDCLASS = "meson"
-DEPENDS = "mozjs-78 gtk4"
+DEPENDS = "mozjs-91"
inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even pkgconfig
-SRC_URI[archive.sha256sum] = "bbdc0eec7cf25fbc534769f6a1fb2c7a18e17b871efdb0ca58e9abf08b28003f"
+SRC_URI[archive.sha256sum] = "f15ad0d45a7d31a1ac4e07479038c0536713cca3c5492ca2f2731c04a3a5f1e9"
SRC_URI += " \
file://0001-Support-cross-builds-a-bit-better.patch \
file://0002-meson.build-Do-not-add-dir-installed-tests-when-inst.patch \
@@ -21,6 +21,7 @@ GIR_MESON_OPTION = ""
EXTRA_OEMESON = " \
-Dinstalled_tests=false \
-Dskip_dbus_tests=true \
+ -Dskip_gtk_tests=true \
"
LDFLAGS:append:mipsarch = " -latomic"