aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-04-04 01:15:33 +0200
committerKhem Raj <raj.khem@gmail.com>2019-04-06 08:22:22 -0700
commite195e7e372b8fd1b8e9f849aa7d5794fb6f40993 (patch)
treecd99c800de1de40f6bfde3d644914f33ca772d85 /meta-gnome
parentf044b936d6986185a890bc82f681b13d19ec3e9a (diff)
downloadmeta-openembedded-contrib-e195e7e372b8fd1b8e9f849aa7d5794fb6f40993.tar.gz
gvfs: Fix missing executable permission flags for files in libexec
At least XFCE sessions turned into unusable state [1] [1] http://lists.openembedded.org/pipermail/openembedded-devel/2019-April/199010.html Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
index 7b9a16e9ea..df9fd50ea1 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
@@ -61,8 +61,16 @@ PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse"
# libcdio-paranoia recipe doesn't exist yet
PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia"
-# Fix up permissions on polkit rules.d to work with rpm4 constraints
do_install_append() {
+ # Fix up permissions on polkit rules.d to work with rpm4 constraints
chmod 700 ${D}/${datadir}/polkit-1/rules.d
chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
+
+ # After rebuilds (not from scracth) it can happen that the executables in
+ # libexec ar missing executable permission flag. Not sure but it came up
+ # during transition to meson. Looked into build files and logs but could
+ # not find suspicious
+ for exe in `find ${D}/${libexec}`; do
+ chmod +x $exe
+ done
}