aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-28 21:52:53 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:27 +0200
commit194322b550b42b0c4e607882284ed7d14f061432 (patch)
treeab68f71e9bdf6120374b7ee62f9ddc1198a1af26 /meta-gnome
parent52919077a3e47bf96a41e4d8471e7b7bb7311031 (diff)
downloadmeta-openembedded-contrib-194322b550b42b0c4e607882284ed7d14f061432.tar.gz
network-manager-applet: Remove all occurances of -Werror in makefiles
There are options like -Werror=foo which get trimmed to =foo and results in compiler fails Fixes | aarch64-bec-linux-gcc: error: =format-security: No such file or directory Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.4.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.4.4.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.4.4.bb
index 5ad1070120..8cec305efe 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.4.4.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.4.4.bb
@@ -20,7 +20,7 @@ PACKAGECONFIG ??= ""
do_configure_append() {
# Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
for i in $(find ${B} -name "Makefile") ; do
- sed -i -e s:-Werror::g $i
+ sed -i -e s%-Werror[^[:space:]]*%%g $i
done
}