aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-08 09:08:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:07 +0200
commitc8d0ebf7f00b6e53fdda973723eaeded3874f8d5 (patch)
tree54eab5f9e28daa5befa1c808ffe3aff26d527b13 /meta-gnome
parent5e725d5cfcfa072f4ac968a5979ad100307bd4b3 (diff)
downloadmeta-openembedded-contrib-c8d0ebf7f00b6e53fdda973723eaeded3874f8d5.tar.gz
gnome-panel: Fix build with gcc-5
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Fix-build-with-gcc-5.patch35
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb13
2 files changed, 44 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Fix-build-with-gcc-5.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Fix-build-with-gcc-5.patch
new file mode 100644
index 0000000000..6b7fc5bec5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/0001-Fix-build-with-gcc-5.patch
@@ -0,0 +1,35 @@
+From 20810fcf329c6e0b48b8e7602565ccc70c7ce62b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 10 May 2015 02:10:59 -0700
+Subject: [PATCH] Fix build with gcc 5
+
+cc1: error: ../../gnome-panel/libpanel-applets-private: No such file or
+directory [-Werror=missing-include-dirs]
+cc1: error: ../../gnome-panel/libpanel-applets-private: No such file or
+directory [-Werror=missing-include-dirs]
+cc1: error: ../../gnome-panel/libpanel-applets-private: No such file or
+directory [-Werror=missing-include-dirs]
+cc1: some warnings being treated as errors
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ gnome-panel/libpanel-applet-private/Makefile.am | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gnome-panel/libpanel-applet-private/Makefile.am b/gnome-panel/libpanel-applet-private/Makefile.am
+index f12dee8..d556f12 100644
+--- a/gnome-panel/libpanel-applet-private/Makefile.am
++++ b/gnome-panel/libpanel-applet-private/Makefile.am
+@@ -8,7 +8,6 @@ AM_CPPFLAGS = \
+ -I$(srcdir) \
+ -I$(top_srcdir)/gnome-panel \
+ -I$(top_builddir)/gnome-panel \
+- -I$(top_builddir)/gnome-panel/libpanel-applets-private \
+ -I$(top_builddir)/gnome-panel/libpanel-util \
+ -DDATADIR=\""$(datadir)"\" \
+ -DPANEL_APPLETS_DIR=\"$(appletsdir)\" \
+--
+2.1.4
+
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
index 4957a99aa4..3a413bd029 100644
--- a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
@@ -1,5 +1,5 @@
SUMMARY = "GNOME panel"
-LICENSE = "GPLv2 & LGPLv2 & GFDLv1.1"
+LICENSE = "GPL-2.0 & LGPL-2.0 & GFDL-1.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
@@ -9,12 +9,17 @@ SECTION = "x11/gnome"
PR = "r7"
-DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ pango libwnck gnome-menus cairo libgweather dbus-glib librsvg libcanberra"
+DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ \
+ pango libwnck gnome-menus cairo libgweather dbus-glib \
+ librsvg libcanberra"
+RDEPENDS_${PN} = "python"
inherit gtk-doc gnome autotools-brokensep gettext pkgconfig gconf
-SRCREV = "6a364b6a4a9beed3da9ca6f5b0dac81eb99dea2a"
-SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32"
+SRCREV = "8292bd2b8a36df7eed3c760899400790cde68590"
+SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32 \
+ file://0001-Fix-build-with-gcc-5.patch \
+ "
S = "${WORKDIR}/git"