aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-21 03:34:38 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:54 +0200
commitd973a83c36f5efe878a542270ad994f16059cee0 (patch)
tree6899e8faff50df761206eaa901ec1b0e2eeb6091 /meta-gnome/recipes-support
parent57fac9d8ac44a6f9dce38b47224aba639eec3b8d (diff)
downloadmeta-openembedded-contrib-d973a83c36f5efe878a542270ad994f16059cee0.tar.gz
keybinder: add recipe 3.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/keybinder/keybinder_3.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb b/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb
new file mode 100644
index 0000000000..d6744a3065
--- /dev/null
+++ b/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "keybinder is a library for registering global key bindings, for gtk-based applications."
+HOMEPAGE = "https://github.com/engla/keybinder"
+LICENSE = "X11"
+SECTION = "devel/lib"
+DEPENDS = "gtk+3 gobject-introspection-native \
+ gtk+ \
+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=1f18f9c6d8b4cfcc7d7804a243a4c0b4"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "736ccef40d39603b8111c8a3a0bca0319bbafdc0"
+PV = "3.0+git${SRCPV}"
+SRC_URI = "git://github.com/engla/keybinder.git;branch=keybinder-3.0 \
+"
+
+RDEPENDS_${PN} = "gtk+"
+
+inherit autotools gtk-doc gobject-introspection
+do_configure_prepend() {
+ touch ${S}/ChangeLog
+}
+
+SRC_DISTRIBUTE_LICENSES += "X11"