aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-01-10 13:13:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-13 11:39:46 +0100
commitd1eb834bd0dc554fa9062b60a43655086b88aadb (patch)
treec41f66c700520562ce31e79a9a36dc81f7d64dec /meta-gnome/recipes-support
parent469cd4ff12b1f94f42d68e049f384873aa0954eb (diff)
downloadmeta-openembedded-contrib-d1eb834bd0dc554fa9062b60a43655086b88aadb.tar.gz
goffice: add patch to use pcre_fullinfo instead of pcre_info
* pcre_info was removed in newer pcre and abiword now fails to build /usr/lib/libgoffice-0.8.so: undefined reference to pcre_info Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch19
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.8.17.bb5
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
new file mode 100644
index 0000000000..ae9370cfcf
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
@@ -0,0 +1,19 @@
+Taken from http://trac.macports.org/ticket/34812
+
+Fixes abiword build failing with:
+/usr/lib/libgoffice-0.8.so: undefined reference to `pcre_info'
+
+Upstream-Status: pending
+
+http://www.linuxfromscratch.org/blfs/view/cvs/x/goffice.html
+--- a/goffice/utils/regutf8.c.orig 2009-09-05 18:52:09.000000000 -0500
++++ b/goffice/utils/regutf8.c 2012-06-09 18:04:29.000000000 -0500
+@@ -155,7 +155,7 @@
+ default: return GO_REG_BADPAT;
+ }
+ } else {
+- gor->re_nsub = pcre_info (r, NULL, NULL);
++ gor->re_nsub = pcre_fullinfo (r, NULL, 0, NULL);
+ gor->nosub = (cflags & GO_REG_NOSUB) != 0;
+ return 0;
+ }
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
index c5d54ab1c8..637ee186f8 100644
--- a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
+++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
@@ -7,8 +7,11 @@ DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+ pango cairo libgsf libpcre li
inherit gnome pkgconfig perlnative
+PR = "r1"
+
SRC_URI += " file://c99math.patch \
- file://nodolt.patch "
+ file://nodolt.patch \
+ file://pcre-8.30.patch"
SRC_URI[archive.md5sum] = "b4c924457163e02daf8a8d2428f51d10"
SRC_URI[archive.sha256sum] = "dd8caef5fefffbc53938fa619de9f58e7c4dc71a1803de134065d42138a68c06"