aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-26 11:58:12 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:40 +0200
commit523fa42dd4904068dd8d9edced02155bd48d3278 (patch)
treea330cfbdf16ac6c264ea2670ab8d72d86d978f3a /meta-gnome/recipes-support
parentc155bd03fd4d4fd7f73202ef70833e17d3adf43b (diff)
downloadmeta-openembedded-contrib-523fa42dd4904068dd8d9edced02155bd48d3278.tar.gz
usermode: Link with libm for powl() API
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch26
-rw-r--r--meta-gnome/recipes-support/usermode/usermode_1.111.bb6
2 files changed, 29 insertions, 3 deletions
diff --git a/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch b/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch
new file mode 100644
index 0000000000..76640b0a1e
--- /dev/null
+++ b/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch
@@ -0,0 +1,26 @@
+From fda0ff49968aebc7b27f9711cf6eb7f6c560adc1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 25 Jul 2017 18:28:15 -0700
+Subject: [PATCH] Makefile.am: Link with libm for powl() API
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 4219f28..2a5ceac 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -69,7 +69,7 @@ dist_pkgdata_DATA = usermode.ui
+ userhelper_SOURCES = userhelper.c userhelper.h shvar.c shvar.h
+ userhelper_CPPFLAGS = $(AM_CPPFLAGS) -DSYSCONFDIR='"$(sysconfdir)"'
+ userhelper_LDADD = liblib.a $(LIBUSER_LIBS) $(GLIB_LIBS) $(PAM_LIBS) \
+- $(SELINUX_LIBS) $(EFENCE_LIBS)
++ $(SELINUX_LIBS) $(EFENCE_LIBS) -lm
+
+ userinfo_SOURCES = userinfo.c
+ userinfo_CPPFLAGS = $(AM_CPPFLAGS) $(PIXMAPDIR_CPPFLAGS) $(SBINDIR_CPPFLAGS) \
+--
+2.13.3
+
diff --git a/meta-gnome/recipes-support/usermode/usermode_1.111.bb b/meta-gnome/recipes-support/usermode/usermode_1.111.bb
index 06e400e52f..c2d73289ee 100644
--- a/meta-gnome/recipes-support/usermode/usermode_1.111.bb
+++ b/meta-gnome/recipes-support/usermode/usermode_1.111.bb
@@ -15,12 +15,12 @@ DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '',
SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \
file://0001-formatting-issues.patch \
-"
+ file://0001-fix-compile-failure-against-musl-C-library.patch \
+ file://0001-Makefile.am-Link-with-libm-for-powl-API.patch \
+ "
SRC_URI[md5sum] = "28ba510fbd8da9f4e86e57d6c31cff29"
SRC_URI[sha256sum] = "3dd0b9639b5bd396b7ea5fada6aaa694dbfdaa3ad06eb95a6eabcdfd02f875c6"
-SRC_URI_append_libc-musl = " file://0001-fix-compile-failure-against-musl-C-library.patch"
-
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
inherit autotools gettext pkgconfig